Sign in to follow this  
David Ramirez

.X files help

Recommended Posts

Greetings everyone,

I've been working on a video game some other peers for our school final project; My task was to learn different 3D software and model every asset and animated character in the game. So I've used Maya 2012, 3DS Max 2012, Blender, Mudbox and Zbrush.

Now the problem starts when I try to export the models to our Xna project, I need to export them as a .x file but EVERY time I try to do this I get an error with MS visual studio.

Currently I'm trying to use Max pandasoft exporter (it the one that has worked the best so far), but to no avail. When I export the model with animation to the game engine I get the same error : "Input model does not contain a skeleton".

I revised the .x file itself and I do see the bones in the stored data, I even tried to code the root bone manually in the .x file, but no matter what I do I get the same error.

Could someoe plz help me a bit, I would greatly appreciate it. It has been 4 or maybe 5 weeks of this and our deadline is SOON!

Thank you

Share this post


Link to post
Share on other sites
Besides your [url="http://www.gamedev.net/topic/631172-how-to-export-a-x-file/"]double post[/url], what exactly is your issue ? Do you have an issue with exporting or importing ? Have you tried some sample .x files (I'm sure there will be some files in the sdk ) ? What happens when you try to export a sample model , same error or is it gone ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this