Jump to content
  • Advertisement
Sign in to follow this  
ysmtek

SDL_gfx and undefined references, undefined references everywhere

This topic is 2215 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi there, I'm trying to draw a circle to a surface using sdl_gfx. I've compiled a .dll, an .a and a .lib of sdl_gfx myself succesfully (I thought). When I link my project to the libraries, i get errors at compile time as such:

e:/development/mingw/bin/../lib/gcc/mingw32/4.7.0/../../../SDL_gfx.lib(SDL_gfxPrimitives.o): In function `fastPixelColor':
E:\DEVELOPMENT\workspace\sdl_gfx\Debug/../SDL_gfxPrimitives.c:198: undefined reference to `_SDL_LockSurface'

and literally hundreds of them. I must have made an oopsie when compiling sdl_gfx or linking my own project to it.

Can anybody explain what I'm doing wrong here? I'm pretty sure this is caused by myself here.

Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement
Okay, after a little reading into what a .dll, an .a and a .lib actually are I concluded the following: I never actually compiled a .lib file, just renamed the artifact to such. For some reason Eclipse really wants a .lib, though. Anyone can help me on how to make such a thing? thank you...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!