Sign in to follow this  

Setting up Nvidia PhysX SDK 3.2

This topic is 1934 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi people,

I have a runtime DEBUG Assertion error when I m trying to setup a basic application using the latest Nvidia PhysX 3.2 sdk. I was just using the documentation and the tutorial mentioned at this blog : [url="http://mmmovania.blogspot.com/2011/05/getting-started-with-physx-3.html"]http://mmmovania.blo...th-physx-3.html[/url] as the only guide. He does mention a small change required for the 3.2 sdk.

This is where I m getting the assertion:[CODE]
gPhysxFoundation = PxCreateFoundation(PX_PHYSICS_VERSION, gDefaultAllocatorCallback, gDefaultErrorCallback);
[/CODE]

The declarations are: [CODE]
PxFoundation* gPhysxFoundation = NULL;
static PxDefaultErrorCallback gDefaultErrorCallback;
static PxDefaultAllocator gDefaultAllocatorCallback;
[/CODE]

And the Assertion is : Expression: (reinterpret_cast<size_t>(ptr) & 15) == 0 in the file: \include\extensions\pxdefaultallocator.h
Now according to the documentation, PhysX does implement a default version of the Default Allocator class and for the windows platform it does call [b]_aligned_malloc(size, 16). [/b]Because this is what is happening. Its not able to align it to 16 bits.

Does anyone know how to solve this issue? I m only starting to learn PhysX and I cannot move forward without solving this issue.

Share this post


Link to post
Share on other sites
Sign in to follow this