Archived

This topic is now archived and is closed to further replies.

wazoo69

cull modes?

Recommended Posts

Hey I was wondering if someone could maybe help me out with cull modes in DX8. I thought I had it figured out, but I''m missing something.. When I set my cullmdoe to D3DCULLMODE_NONE, everything appears okay except my x-axis translations are flipped (so translations specified as +x move to the LEFT rather than the RIGHT).. Does this have to do with the way my vertexes are specified within my vertex buffer?? thanks, Wazoo

Share this post


Link to post
Share on other sites
"Does this have to do with the way my vertexes are specified within my vertex buffer??"

Agree so if your x-axis in model space are flipped then flip it back..
by putting -ve

Share this post


Link to post
Share on other sites
Yes putting CULL mode to NULL does this, the only reason you should use CULL_CW or CULL_CCW is that the engine generally works alot faster as it is only checking for one side of your polygons and not two. I.e. if you created a square plane and used CULL_CW you would only see one side. Thats why sometimes, if you cant see your polygon on the screen try spinning the world around the y axis 180 degs, or moving the camera to point back on itself.

Share this post


Link to post
Share on other sites
Yes putting CULL mode to NULL does this, the only reason you should use CULL_CW or CULL_CCW is that the engine generally works alot faster as it is only checking for one side of your polygons and not two. I.e. if you created a square plane and used CULL_CW you would only see one side. Thats why sometimes, if you cant see your polygon on the screen try spinning the world around the y axis 180 degs, or moving the camera to point back on itself.

Share this post


Link to post
Share on other sites
Thanks MatthewEva!

I just don''t remember ever needing to wonder why on earth my +ive x values were heading in the -ive screen positions, until I started fooling around with Cullmode...(before I never bothered with it and relied on the default setting)

Just want to make sure I''m understanding what''s happening, and I think I am now...thanks!

Share this post


Link to post
Share on other sites