Jump to content
  • Advertisement
Sign in to follow this  
Aluthreney

App won't launch in android virtual machine

This topic is 2070 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

For the past few days I've been setting up everything I need to start developing an android game with the Gameplay 3D game engine. I already have everything setup and working, but I have one problem: I can't run any of the engine's game samples on the avd that comes with android sdk. I don't get any errors when I debug and install the game with ant and the app appears in the avd, but when I click on it to run, a black screen appears for a few moments and then it goes back to the app library. I don't understand how to fix this because I'm not getting any errors. I searched around for the last few days, but I haven't found any situation that resembles mine. I'm developing on ubuntu 12.04 64 and this is what I'm using:

- Android NDK r8
- Android SDK r21
- Gameplay 3D engine
- Apache Ant
- Codeblocks 10.05

I've compiled the same samples in codeblocks to run in linux and it worked fine, so I don't think the problem is coming from the engine. Then again, a friend of mine tried running the samples on his phone, but he had the same results as in the virtual machine. I'm really confused sad.png

please help

Alubiggrin.png

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!