• Advertisement
Sign in to follow this  

vc 2012 error LNK1104

This topic is 1911 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Been pounding my head whole day trying to solve this link error.
But i'm pretty sure it has something to do to with this line:
[source]
std::vector< std::unique_ptr< LoggingOutputI > > _outputs;
[/source]
when i remove all references to this it compiles, else all i get is this


Build started 2012-11-30 23:35:54.
1>Project "D:\Projects\Cyb\build\tests\test1.vcxproj" on node 2 (Build target(s)).
1>Link:
C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\bin\link.exe /ERRORREPORT:PROMPT /OUT:"D:\Projects\Cyb\build\tests\Debug\test1.exe" /INCREMENTAL /NOLOGO kernel32.lib user32.lib gdi32.lib winspool.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comdlg32.lib advapi32.lib ..\framework\Debug\framework.lib /MANIFEST /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /manifest:embed /DEBUG /PDB:"D:/Projects/Cyb/build/tests/Debug/test1.pdb" /SUBSYSTEM:CONSOLE /STACK:"10000000" /TLBID:1 /DYNAMICBASE /NXCOMPAT /IMPLIB:"D:/Projects/Cyb/build/tests/Debug/test1.lib" /MACHINE:X86 /SAFESEH /machine:X86 /debug test1.dir\Debug\test1.obj
1>LINK : fatal error LNK1104: cannot open file 'D:\Projects\Cyb\build\tests\Debug\test1.exe'
1>Done Building Project "D:\Projects\Cyb\build\tests\test1.vcxproj" (Build target(s)) -- FAILED.
Build FAILED.


Attached my project as a small rar file, if anyone wants to test it. needs cmake installed
Thx /Jezper

Share this post


Link to post
Share on other sites
Advertisement

Try updating your project from the PROJECT menu.


While I could not find any update thing under the project menu, I have made clean rebuilds of the solution.
I've even removed all project files and remade them with cmake.
Both without solving the issue.

Share this post


Link to post
Share on other sites
Hello this issue seems quite common. Seems to have to do with some setting in visual studio. This is not for your version of visual studio but the option should technically still be there. Has something do due with source stepping being on under debugging general and needs to be disabled.

http://stackoverflow.com/questions/3906404/link-fatal-error-lnk1104-cannot-open-file-d-myproj-exe

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement