• Announcements

    • khawk

      Download the Game Design and Indie Game Marketing Freebook   07/19/17

      GameDev.net and CRC Press have teamed up to bring a free ebook of content curated from top titles published by CRC Press. The freebook, Practices of Game Design & Indie Game Marketing, includes chapters from The Art of Game Design: A Book of Lenses, A Practical Guide to Indie Game Marketing, and An Architectural Approach to Level Design. The GameDev.net FreeBook is relevant to game designers, developers, and those interested in learning more about the challenges in game development. We know game development can be a tough discipline and business, so we picked several chapters from CRC Press titles that we thought would be of interest to you, the GameDev.net audience, in your journey to design, develop, and market your next game. The free ebook is available through CRC Press by clicking here. The Curated Books The Art of Game Design: A Book of Lenses, Second Edition, by Jesse Schell Presents 100+ sets of questions, or different lenses, for viewing a game’s design, encompassing diverse fields such as psychology, architecture, music, film, software engineering, theme park design, mathematics, anthropology, and more. Written by one of the world's top game designers, this book describes the deepest and most fundamental principles of game design, demonstrating how tactics used in board, card, and athletic games also work in video games. It provides practical instruction on creating world-class games that will be played again and again. View it here. A Practical Guide to Indie Game Marketing, by Joel Dreskin Marketing is an essential but too frequently overlooked or minimized component of the release plan for indie games. A Practical Guide to Indie Game Marketing provides you with the tools needed to build visibility and sell your indie games. With special focus on those developers with small budgets and limited staff and resources, this book is packed with tangible recommendations and techniques that you can put to use immediately. As a seasoned professional of the indie game arena, author Joel Dreskin gives you insight into practical, real-world experiences of marketing numerous successful games and also provides stories of the failures. View it here. An Architectural Approach to Level Design This is one of the first books to integrate architectural and spatial design theory with the field of level design. The book presents architectural techniques and theories for level designers to use in their own work. It connects architecture and level design in different ways that address the practical elements of how designers construct space and the experiential elements of how and why humans interact with this space. Throughout the text, readers learn skills for spatial layout, evoking emotion through gamespaces, and creating better levels through architectural theory. View it here. Learn more and download the ebook by clicking here. Did you know? GameDev.net and CRC Press also recently teamed up to bring GDNet+ Members up to a 20% discount on all CRC Press books. Learn more about this and other benefits here.
Sign in to follow this  
Followers 0
Chad Smith

Monitor Haze

18 posts in this topic

I wanted to see if I could get some help with this. I have two 24" Asus Monitors connected to my computer. When I first got them I worked with the setting a little bit and got them about perfectly balanced with color, brightness, and contrast. Then one day I was messing with the settings once again to check something out and ever since then my main monitor has seemed to have a weird haze on it. Blacks are not blacks, more gray, and even the darker blues seem to have a little gray. When I compare this to my second monitor everything on my second monitor is perfect. Black is excellent and the colors seem very true.

I have double checked the monitor settings on both monitors and they match up perfectly. I have even tried to use the Monitor Calibration app on Windows 8 on this monitor and I can't quite seem to get it to look as good as my second monitor.

Anyone have any tips for me to try? I do not believe it is a monitor defect because it was perfect until that one time I was going through the settings to look at something. Ever since then something has been a little weird on it but can't seem to find it after double checking all the settings.

Thanks.
0

Share this post


Link to post
Share on other sites
Is there a way of resetting to factory defaults? I assume you've already thought of this but in case you haven't it's probably worth looking for, because it would presumably either fix the problem or give you evidence that it's an actual hardware defect.
0

Share this post


Link to post
Share on other sites
It sounds like you might have turned on some kind of "movie mode" or altered the color temperature somehow. Are you using an analog or digital signal?
0

Share this post


Link to post
Share on other sites
My second monitor is actually connected just by VGA while my main monitor is the one that is connected via HDMI.

I have set my main monitor back to factory settings and then set it up exactly like my second monitor but it has seemed to do the same thing. I am going set them both back to factory default and see what I find.

I have tried every mode avaliable on the monitor and have checked the color temperatures. They both are the same it seems.
0

Share this post


Link to post
Share on other sites
[quote name='Prinz Eugn' timestamp='1354931761' post='5008315']
Have you tried switching cables? I.e. seeing if it's a hardware issue?
[/quote]

I honestly don't know why I didn't just switch the cables out in the first place. I just tested that out after resetting them both to factory default settings and still seeing the issue.

Results: Now the 2nd Monitor has the haze effect and the Main monitor is perfect! So from this it seems as if it is the HDMI Cable! Either the HDMI Cable it self or maybe it is internal with the HDMI cable. I have another HDMI cable that I use to connect my laptop to my TV when my friend/roommate wants to watch something. I'll test that one out on the monitors and see what I find out.

PS: they are two different brand HDMI cables that I use too. So if that works it is possible that the brand HDMI cable I got just isn't good. Though the display was good before.

EDIT: Just tried my other HDMI Cable out. I used it on my second monitor (the one that was originally perfect) and while it did seem to help the blacks still seem to have a weird haze while compared to the monitor plugged in with VGA. I will mess with the settings a little bit to see if that will fix it, but if it doesn't then I do have one more HDMI cable that I could try out (though the one I am now using is a pretty high quality HDMI cable and the one laying around is a cheaper one). If that one doesn't work either then it looks like it could be the HDMI input on the laptop that could be having the issue internally. Edited by Chad Smith
0

Share this post


Link to post
Share on other sites
Well I'm not sure if this is true or not generally. But in my recent experience, HDMI is crap. I get terrible image quality with HDMI and instead I prefer to use traditional PC connections or SVGA for TV.

In particular, I plugged my Asus 24" HDMI monitor (my main monitor when at my desktop) into my Alienware laptop using a good HDMI cable and the image quality was just terrible, I mean really terrible, gray, washed out, fuzzy. Completely unacceptable image quality for us PC users. So I had to dig up a spare VGA cable and that provided the normal 'good' quality image.

That experience made a real impression on me that HDMI is rubbish on PC's, and that PC manufacturers don't implement it at all correctly. Edited by Gavin Williams
0

Share this post


Link to post
Share on other sites
[quote name='Gavin Williams' timestamp='1354940610' post='5008357']
Well I'm not sure if this is true or not generally. But in my recent experience, HDMI is crap. I get terrible image quality with HDMI and instead I prefer to use traditional PC connections or SVGA for TV.

In particular, I plugged my Asus 24" HDMI monitor (my main monitor when at my desktop) into my Alienware laptop using a good HDMI cable and the image quality was just terrible, I mean really terrible, gray, washed out, fuzzy. Completely unacceptable image quality for us PC users. So I had to dig up a spare VGA cable and that provided the normal 'good' quality image.

That experience made a real impression on me that HDMI is rubbish on PC's, and that PC manufacturers don't implement it at all correctly.
[/quote]

Well it is just weird to me because if I plug by laptop into my 42" TV to let's say watch a movie or something the display seems perfect. It's like I am just using a very big monitor. Though my TV does have a setting I can change for when it is plugged into a PC. When I do that it automatically changes some things and makes it even better (though mostly it seems that just gets rid of any input lag I might notice before).

I changed some settings around on my monitor connected with this other HDMI cable and it is a lot better than it was with the other HDMI Cable. It is not 100% perfect match but if you were to just sit down and start working on this station then you wouldn't be able to tell the difference.

So that may be true about HDMI on PC's (I haven't heard of any other stories like that though), I do only have one VGA port on this Laptop or I would just use the other VGA cord I do have.
0

Share this post


Link to post
Share on other sites
Glad you got i figured out (more or less)!

I had an issue with HDMI as a monitor cable a while back, but only because for some reason my graphics card control panel thing had HDMI settings under some bizarre sub-menu that took forever to find.
0

Share this post


Link to post
Share on other sites
Yeah, HDMI never worked well either on my monitor/graphics card. It always had these weird black borders and just looked all fuzzy. DVI it is for me.
0

Share this post


Link to post
Share on other sites
To me it sounds like your video card is operating in "limited" RGB mode (where each channel's value ranges from 16..240 rather than the full 0..255) - you should be able to change this. In Catalyst Control Center it's under My Digital Flat-Panels, Pixel Format - select "RGB 4:4:4 Pixel Format PC Standard (Full RGB)" for best results.

[quote name='Bacterius' timestamp='1355012407' post='5008644']
Yeah, HDMI never worked well either on my monitor/graphics card. It always had these weird black borders and just looked all fuzzy. DVI it is for me.
[/quote]

The black borders are likely coming from your graphics card. Some TVs emulate the old CRT overscan by default and scale up the picture (meaning that the edges of the image are lost) so to compensate video cards tend to underscan by default (so that all that is lost is some black borders rather than, say, your taskbar). In Catalyst Control Center this can be adjusted under My Digital Flat-Panels, Scaling Options (adjust the "Underscan-Overscan" slider to 0%).
0

Share this post


Link to post
Share on other sites
[quote name='benryves' timestamp='1355093641' post='5008910']
To me it sounds like your video card is operating in "limited" RGB mode (where each channel's value ranges from 16..240 rather than the full 0..255) - you should be able to change this. In Catalyst Control Center it's under My Digital Flat-Panels, Pixel Format - select "RGB 4:4:4 Pixel Format PC Standard (Full RGB)" for best results.

[quote name='Bacterius' timestamp='1355012407' post='5008644']
Yeah, HDMI never worked well either on my monitor/graphics card. It always had these weird black borders and just looked all fuzzy. DVI it is for me.
[/quote]

The black borders are likely coming from your graphics card. Some TVs emulate the old CRT overscan by default and scale up the picture (meaning that the edges of the image are lost) so to compensate video cards tend to underscan by default (so that all that is lost is some black borders rather than, say, your taskbar). In Catalyst Control Center this can be adjusted under My Digital Flat-Panels, Scaling Options (adjust the "Underscan-Overscan" slider to 0%).
[/quote]

I believe this was my actual problem, thanks for the reminder. I prefer the HDMI cable for my laptop-monitor connection since it's significantly less bulky and more convenient to deal with (not having to choose between a weak connection or messing with screws).
0

Share this post


Link to post
Share on other sites
[quote name='benryves' timestamp='1355093641' post='5008910']
To me it sounds like your video card is operating in "limited" RGB mode (where each channel's value ranges from 16..240 rather than the full 0..255) - you should be able to change this. In Catalyst Control Center it's under My Digital Flat-Panels, Pixel Format - select "RGB 4:4:4 Pixel Format PC Standard (Full RGB)" for best results.

[/quote]

I'll check that out soon. My laptop runs with the Intel HD 4000 Integrated Card and switches a discrete Nvidia card when it needs too. Will I be able to find this setting in the Intel Control panel or something? Do ya know?
0

Share this post


Link to post
Share on other sites
[quote name='Chad Smith' timestamp='1355207828' post='5009353']
[quote name='benryves' timestamp='1355093641' post='5008910']
To me it sounds like your video card is operating in "limited" RGB mode (where each channel's value ranges from 16..240 rather than the full 0..255) - you should be able to change this. In Catalyst Control Center it's under My Digital Flat-Panels, Pixel Format - select "RGB 4:4:4 Pixel Format PC Standard (Full RGB)" for best results.

[/quote]

I'll check that out soon. My laptop runs with the Intel HD 4000 Integrated Card and switches a discrete Nvidia card when it needs too. Will I be able to find this setting in the Intel Control panel or something? Do ya know?
[/quote]
I would have expected you to be able to, though I don't have personal experience with HDMI in Intel or Nvidia control panels so I'm afraid I couldn't point you to the relevant settings. All I know is that AMD cards default to "HDMI means dumb TV", at least, and your symptoms sound similar to mine.
0

Share this post


Link to post
Share on other sites
I use a hdmi cable for my monitor and i also had the black borders (fixed through gpu control panel) and sometimes get the washed out colors randomly (which i fix by poking at the contrast and brightness settings of the monitor...)
0

Share this post


Link to post
Share on other sites
[quote name='benryves' timestamp='1355243690' post='5009447']
[quote name='Chad Smith' timestamp='1355207828' post='5009353']
[quote name='benryves' timestamp='1355093641' post='5008910']
To me it sounds like your video card is operating in "limited" RGB mode (where each channel's value ranges from 16..240 rather than the full 0..255) - you should be able to change this. In Catalyst Control Center it's under My Digital Flat-Panels, Pixel Format - select "RGB 4:4:4 Pixel Format PC Standard (Full RGB)" for best results.

[/quote]

I'll check that out soon. My laptop runs with the Intel HD 4000 Integrated Card and switches a discrete Nvidia card when it needs too. Will I be able to find this setting in the Intel Control panel or something? Do ya know?
[/quote]
I would have expected you to be able to, though I don't have personal experience with HDMI in Intel or Nvidia control panels so I'm afraid I couldn't point you to the relevant settings. All I know is that AMD cards default to "HDMI means dumb TV", at least, and your symptoms sound similar to mine.
[/quote]

I'll have to check into it. I was poking through the Intel settings with the multiple displays to see if their were some settings i could change. One thing I found is that in the Intel Control Panel settings it kept listing the monitor that is plugged in via HDMI as a TV. So I'll have to check into it when I get home and next time my laptop is docked.
0

Share this post


Link to post
Share on other sites
Just wanted to reply back and say that it seems I might have solved the problem.

I went searching around the Intel Control Panel to see if I could anything. Nothing seemed to do anything. I then thought "what the heck, lets try this monitor out using YCbCr color definition" Applied the setting and I immediately could tell the difference. The screen was darker, but in a good way. Blacks are now black and not grey, colors seem to be very natural and pop right off the screen. Cloned both displays to compare and they both look virtually identical. Though does anyone know if I should actually be doing this? Am I just missing something right now?

Also, wanted to pose this question in here since it does have to do with my display. In Windows 8 would it be possible to drive my HDMI display (the one that was having the issue) off my Nvidia GTX 660m card and the VGA one off my Integrated 4000 card? Is this possible? Is it a BIOS change? Google hasn't quite helped me on this. It's no problem if I can't. Would just help me with the display settings as I did find under the Nvdia Control Panel that it was set to a limited RGB mode. I did change that to use full values though since the card isn't driving the displays all the time it wouldn't do anything.

Thanks.
0

Share this post


Link to post
Share on other sites
[quote name='Chad Smith' timestamp='1355475658' post='5010535']
I went searching around the Intel Control Panel to see if I could anything. Nothing seemed to do anything. I then thought "what the heck, lets try this monitor out using YCbCr color definition" Applied the setting and I immediately could tell the difference[/quote]
It's fine, though it may depend on the video card and monitor and how they translate the native RGB to YCbCr and back again - it seems both do a better job of this than it does with RGB, so go for it (greens are overly vivid on my monitor in YCbCr so I tend to stick to RGB).
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0