Sign in to follow this  
Followers 0
flux101

Going crazy - 3D at GL 3.2 doesnt work

3 posts in this topic

Hello everybody,
there is a situation that making me going crazy for at least a week. Im converting my engine to opengl 3.2. Works fine,as long as i only draw a colored fullscreen quad. I tried to display a cube, so ive created a perspective matrix, view matrix and model matrix, apply them to a shader and multiply them with the position of the vector. Nothing... (Black screen)

I had thought there must be a problem in my 3D math library (im not really a math whiz...), so i had looked for errors, other implementations and the problem didnt get solved. Maybe there is something little, something ive failed to notice... Now im asking you guys, perhaps you find my mistake.

Lets start with some basic matrix functions im using:
[source lang="cpp"]inline Mat4 Mat4::Perspective(float fov, float aspect, float zNear, float zFar)
{
float h = tanf(fov * M_PIOVER360);
float w = h * aspect;
return Mat4(2.0f * zNear / w, 0.0f, 0.0f, 0.0f,
0.0f, 2.0f * zNear / h, 0.0f, 0.0f,
0.0f, 0.0f, -(zFar + zNear) / (zFar - zNear), -2.0f * zNear * zFar / (zFar - zNear),
0.0f, 0.0f, -1.0f, 0.0f);
}[/source]
In camera class: mmProj = Mat4::Perspective(75.0f, 800.0f / 600.0f, 1.0f, 512.0f);

[source lang="cpp"]inline Mat4 Mat4::LookAt(const Vec3& eye, const Vec3& center, const Vec3& up)
{
Vec3 vZAx = Vec3(eye - center);
vZAx.Normalize();
Vec3 vXAx = Vec3::Cross(up, vZAx);
vXAx.Normalize();
Vec3 vYAx(Vec3::Cross(vZAx, vXAx));

return Mat4(vXAx.x, vYAx.x, vZAx.x, 0,
vXAx.y, vYAx.y, vZAx.y, 0,
vXAx.z, vYAx.z, vZAx.z, 0,
-Vec3::Dot(vXAx, eye), -Vec3::Dot(vYAx, eye), -Vec3::Dot(vZAx, eye), 1);
}[/source]
in camera class: mmProj = Mat4::LookAt(mvPos, Vec3(0, 0, 0), Vec3(0,1,0));

Model matrix is set to identity.

Vertex shader:
[source lang="cpp"]#version 150

layout(location = 0) in vec3 v3Pos;
in mat4 m4Proj;
in mat4 m4View;
in mat4 m4Model;

void main()
{
mat4 mvp = m4Model*m4View;
mvp = m4Proj * mvp;

gl_Position = mvp*vec4(v3Pos, 1.0);
}[/source]

Fragment shader:
[source lang="cpp"]#version 150

out vec4 v4Frag;

void main()
{
v4Frag = vec4(1,0,0,1);

}[/source]

My mesh draw routine:
[source lang="cpp"]glBindVertexArray(miId);
glBindBuffer(GL_ELEMENT_ARRAY_BUFFER, miBufId[1]);

glEnableVertexAttribArray(0);

if(miIndexCount != 0) glDrawElements(GL_TRIANGLES, miIndexCount, GL_UNSIGNED_SHORT, 0);
else glDrawArrays(GL_TRIANGLES, 0, miVertexCount);

glDisableVertexAttribArray(0);
glBindBuffer(GL_ELEMENT_ARRAY_BUFFER, 0);
glBindVertexArray(0);[/source]

In my setup i only call:
[source lang="cpp"]glEnable(GL_DEPTH_TEST);
glDepthFunc(GL_LESS);[/source]

Im checking with glGetError every 30ms, but there is no error too.

So, what had i done wrong... please help...
0

Share this post


Link to post
Share on other sites
i am not sure but i think if you use opengl 3 or higher you should change

#version 150
to
#version 320

depending on used version, maybe this helps
0

Share this post


Link to post
Share on other sites
In your vertex shader, you are passing your matrices as vertex attribute ("in" keyword). Replace this keyword with "uniform" to pass them as uniform values.

PS : #version 150 is correct for OpenGL 3.2. The new version notation (using opengl version) started since opengl 3.3
1

Share this post


Link to post
Share on other sites
Omg, thanks...
Now im getting GL error 1282 (Invalid operation). But only if i use the matrices for gl_Position in my shader (gl_Position = m4Proj*(m4Model*m4View)*vec4(v3Pos, 1.0);). There is no error then i set gl_Position to vec4(v3Pos, 1.0f).
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0