Sign in to follow this  
stitchs_login

Unity 'Completed' Pong Project; looking for Critique.

Recommended Posts

Hey guys,

I have been working on this for about a month and half now, with two weeks spent on the first iteration and the last 3-4 on changes suggested by this wonderful community.

 

I have worked my way through the the list and am now (in loose quotations) finished. I am pleased with what I have learned on the way, and how I will take some of it forward. I also realise that my code was nowhere near what it should have been and have revised much of it.

 

There are still some issues:

  • Hard-coded/cumbersome state machine in Game.h (to be revised in next project)
  • Ball sprite appearing white (this is one I could use some advice on)
  • Game over text being highlighted incorrectly
  • Lack of sound/save functionality.
  • Players should probably by local to Game.h and opposed to Arena.h

 

 

Could I get you guys to try it out, and have a gander at the code as some new feedback would be excellent to take into the next project. Please find this below.

 

I write this late and will probably think of extra things, and add them tomorrow.

 

Regards,

 

Stitchs.

Share this post


Link to post
Share on other sites
I tried it out.
Nice pong game you have here, but you should seriously consider capping FPS.
Also when paddle can overlap numbers (when up most in screen), could reduce the playable terrain size to make area just for tracking stats.
Difference paddle color from the text color. (Just recolor the image)

Also if it took you one and a half month for this, i would ask how many work hours did you do a day? or/and are you still learning?

EDIT:: That AI so strong, i almost lost was like 5-4. I love it, great for lol's. Edited by BaneTrapper

Share this post


Link to post
Share on other sites
This reply is on the same lines as my [url="http://www.gamedev.net/topic/635214-pong-project-near-completion-looking-for-critique/#entry5006455"]earlier analysis[/url]. Many of the suggestions are stylistic in nature, but I believe that there are certain styles that are bug prone, difficult to read or that cause confusion. What I mean is that most of them are somewhat subjective, the important thing is that you've completed your project and are happy with it.
 
Here are some notes from a short review of the code. Where possible, I highlight a specific piece of code, but sometimes the underlying issue is present in multiple locations.
 
[code]
// np prefix to represent stack objects.
Arena npPongArena;
GUIMenu npMainMenu, npGameOverMenu;
[/code]
 
Member variables that are not pointers are not necessarily "stack" objects. After all, they may be located on the heap if the enclosing object(s) are dynamically allocated. I would question the need for a special prefix to such objects, since you don't appear to use it with builtin types or enumeration values.
 
[code]
int Game::RunGame()
{
    sf::RenderWindow gameWindow_(/ * ... */);
}
[/code]
Code conventions that use trailing underscores usually reserve them for member variables, not automatically allocated objects like this. 
Such a pre/post fix should have a specific reason. The point is not to decorate every symbol. It should highlight exceptional cases, such as pointers, references, member variables, global or static data. Automatic variables and value parameters are "easy", their declarations are usually visible, and they are more likely to stay in one's mind than some of the more complex examples I listed above.
 
[code]
MyHelper::FloatToString(frameRate_, true)
[/code]
Quick test: what does FloatToString do when passed false? Avoid boolean parameters where possible, particularly where the input is a literal. Better would be to use a enumeration of the desired behaviour:
[code]
enum FloatFormatting {
    FloatFormattingNone,
    FloatFormattingTruncate
};
 
MyHelper::FloatToString(frameRate_, MyHelper::FloatFormattingTruncate);
[/code]
But even still I would advise against trying to overload these two distinct behaviours into the same function. Let the caller use IntToString if necessary:
[code]
int truncatedFrameRate = static_cast<int>(frameRate_);
std::string whatever = IntToString(truncatedFrameRate);
[/code]
In this specific case, you might avoid this by not storing the frame rate as a float. Calculating the frame rate every single frame can lead to the frame rate being difficult to read if your frame times fluctuate. What I tend to do in my games is to maintain a frame counter and a timer, and when the timer exceeds a second I update the FPS string value.
 
[code]
GUIMenu::GUIMenu(sf::Vector2i position, int numOptionsIn, int firstSelectable)
[/code]
Mixing the "options" container with non-selectable options is confusing. I'd probably design this class to contain an (optional) "description" - which is text that would be printed above the options but is not considered selectable.
 
Alternatively, you could have the concept of a "MenuEntry", which might be selectable by default, but the caller can create a non-selectable instance too. This would allow you to, for example, have a main menu with "disabled" entries, such as a "Load Game" entry which is not selectable (and probably visually de-emphasised) until the user has created a save game:
[code]
class MenuEntry {
public:
     enum EntryState {
         Disabled,
         Enabled,
     };
 
     MenuEntry(const std::string &name, EntryState state = Enabled);
 
     // ...
};
 
class Menu {
public:
    Menu(/* ... */);
 
    void addEntry(const MenuEntry &entry);
 
    // ...
};
[/code]
 
[code]
// Loop through keys, without the need to check the event queue because
// I am using the Windows' GetInput(). I am unable to check with the
// the queue as this method is not called in the event polling loop.
// Instead, I just input the counter into the Code structure and see if
// it matches, in order to update curButtonState_.
// TODO: need to include a boolean check to see if a key has been pressed, before looping on every go.
[/code]
Consider having another function, HandleInput() or HandleEvent(), which can be called as part of the event polling loop. Right now, your polling loop discards all the events, and you go to great pains elsewhere to reconstruct this information.
 
[code]
sf::Sprite& Paddle::GetSprite()
{
    if(spriteLoaded_)
    {
        return paddleSprite_;
    }
}
[/code]
This is a bug. All code paths should always return a value. You need to heed compiler warnings about this. If your compiler doesn't warn you about this, turn the warnings up as far as they will go. Ideally, use the compiler switch "treat warnings as errors". 
 
[code]
void Paddle::OnWallCollision(sf::Vector2f &colAreaPosition, sf::Vector2f &colAreaDimensions)
{
    // ...
    return;
}
[/code]
This is really minor, but it is not necessary to put an explicit return as the last line in a function. Leaving one in flags in my mind because it makes me think that this should be nested in a condition or loop that you have forgotten.
 
[code]
if(!paddleImage_.LoadFromFile(filename))
{
    // Handle error...
}
else
{
    // Handle success...
}
[/code]
When you're covering both cases, it is easier to read the code if you write the "positive case" first:
[code]
if(paddleImage_.LoadFromFile(filename))
{
    // Handle success ...
}
else
{
    // Handle error...
}
[/code]
 
[code]
static sf::Image paddleImage_;
static bool imageLoaded_;
[/code]
This is fine for a small game. For larger games, you'll probably want to avoid relying on global state. Due to this state, it is actually difficult to unit test the Paddle class.
 
Also, having a member function LoadSprite() which simultaneously interacts with both the static class state and the instance state is confusing and suprising. It might be better to consider a static member function to initialise the static data, and then a member function to "apply" this to the Paddle instances.
 
Your Paddle code has lots of branches for handling the presence/absence of a loaded image. One alternative to this is to use a polymorphic type. Consider:
[code]
class PaddleRenderer {
public:
    virtual ~PaddleRenderer() {}
 
    virtual void render(const Paddle &paddle) = 0;
};
 
class PrimitivePaddleRenderer : public PaddleRenderer {
public:
    // Fill a rectangle at the paddle's position with the necessary colour
    virtual void render(const Paddle &paddle);
};
 
class ImagePaddleRenderer : public PaddleRenderer {
public:
    ImagePaddleRenderer(const sf::Image &image);
 
    // Fill a rectangle at the paddle's position with the necessary colour
    virtual void render(const Paddle &paddle);
     
private:
    // Maybe you need a sf::Sprite and/or a sf::Image here, I'm not too familiar with SFML
};
 
// Factory function
std::unique_ptr<PaddleRenderer> createRenderer() {
    sf::Image image;
    if(image.LoadFromFile("images/paddle")) {
        return std::unique_ptr<PaddleRenderer>(new ImagePaddleRenderer(image));
    }
 
    // It would be nice to log the I/O error here...
    return std::unique_ptr<PaddleRenderer>(new PrimitivePaddleRenderer());
}
[/code]
 
[code]
void OnWallCollision(sf::Vector2f &colAreaPosition, sf::Vector2f &colAreaDimensions);
[/code]
A position and dimensions? Sounds like a rectangle... Actually you do have a comment to this effect in Ball.h
 
[code]
//Paddle reference?
Paddle pPaddle_;
[/code]
This is inconsistent with the remainder of your coding convention.
 
[code]
Player::Player(/* ... */, Paddle &paddleIn)
{
    // ...
    pPaddle_ = paddleIn;
}
[/code]
You are copying the paddle here. This isn't necessarily wrong, but it is surprising. I hope that Paddle, and all its (recursive) members correctly handle being copied.
 
[code]
enum Direction2D
{
    DirNone, // Default direction
    DirUp, // Up
    DirDown, // Down
    DirLeft, // Left
    DirRight, // Right
    DirAxisX, // Represents the horizontal axis
    DirAxisY // Represents the vertical axis
};
[/code]
This appears to be two distinct enumerations hiding inside the same one. I'd prefer separate Direction and Axis enumerations.
 
[code]
class Arena
{
    // ...
    sf::Rect<float> arenaArea_;
    Ball npBall;
    std::vector<Player> players;
};
[/code]
I can't see any consistency in the naming convention here. sf::Rect<float>, Ball and std::vector<Player> are all user defined value types. These are all member variables. Why don't they all have a trailing underscore? Why don't they all have the "np" prefix?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Announcements

  • Forum Statistics

    • Total Topics
      628332
    • Total Posts
      2982120
  • Similar Content

    • By abarnes
      Hello!
      I am a game development student in my second year of a three year program and I would like to start building my portfolio. I was thinking of creating some games to show what I can do to potential employers since I wont have any work related experience when I graduate. But as I'm sure you all know there are tons of ways to approach developing/designing a game and I'm curious if anyone had any insight as to any "standards" that come with this? Is it okay to use game engines like Unity, Unreal, Game Maker etc? Or would it be better to make a game from scratch to better show case your skills? Any and all advice will be greatly appreciated!
    • By Hilster
      Hello 2D Artists,
      I've started making a 2D Puzzle Adventure game for mobile and I'm looking for someone who would want in on creating assets for the game. The core of the programming is pretty much complete, you can walk within the grid laid out and push boxes, when there is an object on top of a pressure pad it will activate the linked objects or if there is one object with multiple linked pressure pads it requires you to activate all points for the object to become active. 

      The level iteration for the game is quick and simple, a Photoshop file that is made of individual pixels that represents objects is put into the game and it creates the level out of those pixels with the assigned objects.
      The objects that need sprites created so far is the character, box, pressure pad, door, trap door, the walls, the stairs and the tiled background.
      I intend to add more objects so the amount I'd like to add will be extended.
      My motivations for posting here is to have something that looks nice to be able to display on my portfolio, so if you're looking for a working game that you can place your art into and improve the look of your portfolio then we're in business.
      Please reply with a few past examples of your art below and I'll be in touch!
    • By thefollower
      Hi
      I have set up my TcpClient to connect to my server and that works fine. But i am a bit confused how i read messages from the network stream with it continuously running via async, without ever closing the connection ?
      My TcpClient Manager class has:
       
      public async Task<bool> Connect(string address, int port) { try { await _tcpClient.ConnectAsync(address, port); IsConnected = true; return true; } catch(Exception e) { Debug.Log(e); return false; } } public async Task<int> Read(byte[] readBuffer) { if (!IsConnected) return -1; using (var networkStream = _tcpClient.GetStream()) { try { var bytesRead = await networkStream.ReadAsync(readBuffer, 0, readBuffer.Length); return bytesRead; } catch (Exception e) { Debug.Log(e); IsConnected = false; return -1; } } }  
      So i thought to just run a co-routine and call Read constantly to get the most recent message, but that doesn't make much sense to me since a co-routine would be blocked with the await. How is this actually done? The MS Docs don't have very good Async examples with the TcpClient class so i don't know fully get how to keep calling Read correctly.
    • By NUITGaming
      Landscaping back ground maid in Unreal 4.18
  • Popular Now