Archived

This topic is now archived and is closed to further replies.

Zook

Weird direct3d error.

Recommended Posts

Zook    134
I have made a d3d program with VC++ 5.0 in Win ME. It works fine, but when I try to run it under Win 2000 on the same computer I get an E_OUTOFMEMORY error when trying to create the d3d device. Does anybody know what causes this problem? I have directx 8.0a installed on both systems.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
quote:
Original post by Vendayan
I''m beginning to think that playing games with Win2000 (spits) is like trying to play monopoly with a 4 year old.


hey, _I_ played monopoly (quite well) when i was 4!

Share this post


Link to post
Share on other sites
CrazedGenius    156
2000 has always treated me very well...

Between the systems, are the graphics cards the same or at least very similar? It''s possible that you are asking for more than the card can give you. This doesn''t like a 2000 issue.

Share this post


Link to post
Share on other sites
Wreakon    121
That error is not weird at all, it means that you are out of system memory, duh. How much RAM does the system have anyway?, Note that Win2k runs more programs in the background resulting in less RAM available.

Share this post


Link to post
Share on other sites
Zook    134
Well I''ve got 256 mb of ram and a geforce2 with 32mb.
That gotta be enough to at least initialize d3d even in 2000.

Share this post


Link to post
Share on other sites
RelisH    122
You are first making a win2k build when you are running it under win2k and not simply copying the one you built from WinME? If you arent then that''s probably the problem.

Share this post


Link to post
Share on other sites
Zook    134
I thought about this too, so installed vc++ in win2k and made a build there, with the same result.
Then I installed a game that uses directx. It couldn''t use anything else than the software renderer. So obviously this has nothing to do with vc++. It''s as if directx wasn''t present, although I know I have installed it. And reinstalled it just to be sure.
Maybe I should reinstall win2k and see what happens. Or maybe just forgetting about the whole thing and throwing win2k away is an even smarter idea.

Share this post


Link to post
Share on other sites
jwalker    122
check the d3d settings in your control panel.
make sure the d3d is set to use hardware render .



{ Stating the obvious never helped any situation !! }

Share this post


Link to post
Share on other sites
ncsu121978    1344
dont throw out win2k.....it is the best OS microsoft has put out yet. ME blows, XP realllllly blows. I liked 98 pretty well. But 2k gives you so much more then 98.

"I pity the fool, thug, or soul who tries to take over the world, then goes home crying to his momma."
- Mr. T

Share this post


Link to post
Share on other sites