Archived

This topic is now archived and is closed to further replies.

Necrosis

Anyone else experiencing the same annoyance?

Recommended Posts

Necrosis    150
Been working my programs, with DirectDraw, in 640*480 resolution (full screen). But the annoyance is everytime I execute my code and then exit the program, it shrinks my VC++ compiler to 640*480 (my desktop runs at 1280*1024) which I have to resize to take up the entire screen again. Strange topic, I know... anyone else that puts up with this? How many more times do I have to remind you? All your base are belong to us!

Share this post


Link to post
Share on other sites
Torn Space    122
Make sure you are killing all the DirectX stuff in the opposite order you are creating them... sounds stupid, but I read it in a FAQ from Microsoft a long time ago.

If that doesn''t work, also make sure you are killing all the DirectX stuff before you kill your main window.

-M

Share this post


Link to post
Share on other sites
Necrosis    150
I experience this with my code, as well as all DDraw examples from LaMothe''s book. I hope I''m not being tought bad habits.

Something I failed to mention, is this is inconsistent. Sometimes my desktop is restored correctly, sometimes I get the shrunk window. And it''s not based on what I run, I noticed, I can compile the same program and exit 10 times, and some of those will restore correctly while other times not. Bleh




How many more times do I have to remind you? All your base are belong to us!

Share this post


Link to post
Share on other sites
redwyre    122
i once ran my code in 320x240 - do you know what msvc looks like then? i think its just all toolbars

i experience the same problem, so i use my current resolution in my code. you could try changeing the screen res before you shut down directx

i just use the display panel to change my res back instantly


redwyre /vivid
keep it real

Share this post


Link to post
Share on other sites
Necrosis    150
What seems to be working well, in it''s own way, is setting the screen res to the same res my desktop runs at, but drawing to it at the smaller res. Lots of black space and tiny little graphic window, but helps. And my computer monitor (it''s a HP, heh) takes ages to switch resolutions, so thats a bonus




How many more times do I have to remind you? All your base are belong to us!

Share this post


Link to post
Share on other sites
Doddler    122
Hell, I have the same issue, so what I do is that I simply don''t maximize the window. I just change the size so that it takes up my whole screen, so when my progs running, it doesn''t change size on me.
-Doddler

Share this post


Link to post
Share on other sites
T-Rex    122
I have had the same issue T_T but with Direct3D 8 even though I have released all my objects so im using the resolution as my desktop.

Share this post


Link to post
Share on other sites