Jump to content
  • Advertisement
Sign in to follow this  
harshman_chris

glsl devil issue

This topic is 2027 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So I am trying to use glsl devil but it crashes on a call glTexImage2D because the bits value is a <Bad Ptr>, this doesnt happen in visual studio 2010, the working directory is set right otherwise the shaders would not load before this.

 

I am at a loss to why this is happening.

 

Any thoughts, anyone had experience with this happening before?

Share this post


Link to post
Share on other sites
Advertisement

If it crashes on glTexImage2D() then the problem should be that the texture was not loaded correctly, and as such the data pointer is invalid, so this as nothing to do with GLSL.

 

Did you check if the texture was loaded correctly from the file?

Check if the path is correct, and also check for errors after loading the texture.

Also, check http://content.gpwiki.org/index.php/DevIL:Tutorials:Basics if you're having doubts.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!