• Advertisement
Sign in to follow this  

Link to older version of Direct3D libs

This topic is 1804 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello. I'm developing s simple application on  different computers. The first has WinXp installed, the second one has Windows 8 installed. On the first one I have DX SDK august 2007, the second one has DX SDK june 2010. When I migrate the source code between the two, I get shader compilation errors, because D3DX effect compiler has changed. If I only migrate the compiled application it works OK, but if I recompile it under Win8 with june 2010 version it fails to compile the shaders.

Can link to older libraries, install the same version of DX SDK on both computers or else ?

Thanks.

Share this post


Link to post
Share on other sites
Advertisement

What is it that the effect compiler is giving you errors about?  In general, the compilers have improved significantly from the 2007 era, so if possible then you should address your source files such that they will compile on both systems.  Without knowing specifically which errors you are getting it is hard to tell how big of a modification it would take...

Share this post


Link to post
Share on other sites

I'd be more inclined to advise that you build using a consistent environment on both machines - same SDK versions, save VS versions, etc.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement