• Advertisement
Sign in to follow this  

global function or static function ?

This topic is 1787 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all,

A design question is with us tonight, I would like to have your opinion.

Imagine a class Vector2,Vector3,Vector4, all of them has a global function to compute the dot product :

 

 

VectorN VectorDot( const VectorN& A, const VectorN& B );
N is 2, 3 and 4.
 

What is the best design, Make it global in the namespace or static for each class ?

 

 

First option :
Namespace::VectorDot( a, b );
Second option :
Namespace::Vector2::Dot( a, b );
 

Same for math function (abs,clamp,sqrt...), global or static in a Math class ?

I was a big user of global function and I have changed to static into a class recently, it's just a design question but it's nice to have differents opinion with experience of each.I have changed because the class can be seen like a scope.

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement

Based on the simple rule "prefer non-friend non-member functions" the obvious answer would be "global" (though technically the static function is just as global with a more annoyingly fiddly scope).

 

Resist the temptation to stuff everything into classes. You want to able to extend your code without touching existing code, which is a lot easier if the functions working with/on your objects are completely independent (and don't need to access private members).

Share this post


Link to post
Share on other sites
Both, except the member function shouldn't be static.

Have a member function (non-static) and a non-member function.

Have one of them call the other. Most likely you'll want the member function to call the global function.


For the math stuff...
Having a bunch of static member function vs a function in a namespace are essentially identical. I prefer a bunch of math functions in a namespace like MathUtil::Somefunc();

Share this post


Link to post
Share on other sites
In maths libraries you often have operations between different types. If you use static functions it's not clear which class they should belong to.

It's more consistent therefore to have all functions as non-member functions in the namespace. Also you get argument dependent lookup and can overload operators.

Share this post


Link to post
Share on other sites

Given that the dot operation is completely specific to the type on which it's operating (i.e. you'd need to write different code for dot for Vector2, Vector3, Vector4, etc....), it's not generic at all, and so I would have a slight preference to put it as a static method on the class itself. This is in contrast to something like std::sort, which is one piece of code that works on many types and makes sense to be global.

Edited by phil_t

Share this post


Link to post
Share on other sites

Given that the dot operation is completely specific to the type on which it's operating (i.e. you'd need to write different code for dot for Vector2, Vector3, Vector4, etc....), it's not generic at all, and so I would have a slight preference to put it as a static method on the class itself. This is in contrast to something like std::sort, which is one piece of code that works on many types and makes sense to be global.

 
Not generic in that it should be made into a template.
 
From my experience it is best to provide two signatures:
 


class Vector3{
...
float Dot( const Vector3 &lhs) const { return DotProduct(this,lhs); }
};

 

float DotProduct(const Vector3 &rhs, const Vector3 &lhs) {...}

 

The same with CrossProduct and other assorted vector/matrix operations.

Edited by frob

Share this post


Link to post
Share on other sites

Personally I prefer to be more specific; i.e. instead of writing a set of overloaded "Dot" functions I'll write "Vector2Dot", "Vector3Dot", "Vector4Dot" (as standalone functions rather than class members) - the reason why is the old chestnut of "reading code is harder than writing it", and this way it's absolutely explicit what types are being operated on.  The extra verbosity is something I accept as a fair tradeoff.

Share this post


Link to post
Share on other sites

In that case, why stop at function names? Why not just do full systems Hungarian everywhere? Then you never have any doubt.

 

 

(BTW, I don't buy that argument, if it wasn't obvious. A dot product is a dot product. The types it operates on are obvious already: vectors. How many components each vector has is up for debate, but if that isn't also obvious from context and variable names, you have bigger naming issues than what to call your dot product function.)

Share this post


Link to post
Share on other sites

Personally I prefer to be more specific; i.e. instead of writing a set of overloaded "Dot" functions I'll write "Vector2Dot", "Vector3Dot", "Vector4Dot" (as standalone functions rather than class members) - the reason why is the old chestnut of "reading code is harder than writing it", and this way it's absolutely explicit what types are being operated on. The extra verbosity is something I accept as a fair tradeoff.


Depends what you consider readable. My preference is to remove redundant text in order to make the rest clearer. I generally know whether I'm working with 2D or 3D vectors, so not having VectorN in the function name lets me focus on the important part: the operation.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement