Sign in to follow this  
Followers 0
skullfalker

Help with IE

4 posts in this topic

Hello everyone,

So I just bought a new laptop with windows 8 on in and everything seems to be working fine at the moment but I ran into this problem while searching the Internet and creating an account on steam. Some images won't show until I manually tell it to show image and other things like the green check marks/red X's that indicate weather or not a username is available, password confirmation is correct and so on are not showing either. Same goes for the password strength bar; it is unchanging. I would normally find a fix myself but I am too tired and too frustrated at the moment so any and all help with fixing this issue is greatly appreciated.

Edit: forgot to mention that I am using IE 10 if anyone didn't already know.

Thanks, skull
0

Share this post


Link to post
Share on other sites

while i do agree that you should get a better browser.

 

This sounds like symptoms of something much worse, did you format the laptop when you got it, or does it still contain all the bloated software the manufacturer sends with it?

0

Share this post


Link to post
Share on other sites
Trying another browser at least helps determine if it's specific to IE, or a more general problem (plus allows the workaround of using the other browser).

Is it just Steam, or some sites, or all sites?
0

Share this post


Link to post
Share on other sites

im using IE10 happily over any other browser, steam loads fine and superfast much like every other site, haven't had any issues with any site.

 

I doubt this is a browser issue tbh, make sure you are up to date with windows update

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0