• Advertisement
Sign in to follow this  

How adjust compiler for NVIDIA OpenGL SDK 10 lib

This topic is 1762 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I wrrite programm in C++ and use g++. There are a few files.

main.cpp - wherein two include directives, and function main,which return 0

is include



#include <iostream>
#include <nvModel.h> // our header from NVIDIA

I wrote makefile:


CC = g++
EXE = nvTest

DIR1 = -I"C:\Program Files (x86)\NVIDIA Corporation\NVIDIA OpenGL SDK 10\common\include"
DIR2 = -I"C:\Program Files (x86)\NVIDIA Corporation\NVIDIA OpenGL SDK 10\common\GLEW\include"
DIR3 = -I"C:\Program Files (x86)\NVIDIA Corporation\NVIDIA OpenGL SDK 10\common\nvModel\include"
DIR4 = -I"C:\Program Files (x86)\NVIDIA Corporation\NVIDIA OpenGL SDK 10\common\nvWidgets\include"
DIR5 = -I"C:\Program Files (x86)\NVIDIA Corporation\NVIDIA OpenGL SDK 10\common\nvImage\include"
DIR6 = -I"C:\Program Files (x86)\NVIDIA Corporation\NVIDIA OpenGL SDK 10\common\nvGUI\include"

LDFLAGS = -L"C:/Program Files (x86)/NVIDIA Corporation/NVIDIA OpenGL SDK 10/common/nvModel/lib"
LIBS = -lnvModel

$(CC) main.cpp $(LDFLAGS) $(LIBS) -o $(EXE) $(INCLUDE)

But g++ return very a lot of errors. These errors printed in file. Download or online see http://yadi.sk/d/0JMHyPEh59nl2

Please, help me. What am I doing wrong?


P.s. I asked about this problem, on a lot of Russian Programmers Forums, but silence...

Share this post

Link to post
Share on other sites

Exemples contains: nvModel.dll, nvModel.lib, nvModel.h, and source files.

Share this post

Link to post
Share on other sites
Sign in to follow this  

  • Advertisement