• Advertisement
Sign in to follow this  

No indices object for reference

This topic is 1693 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When I'm creating a cube object in my class and trying to use my CreateVertexBuffer and CreateIndicesBuffer, I'm getting the error "object reference not set to an instance of an object". Even tho I'm creating the cube the right way, why is this happening?

 

public class Cube
{
    public GraphicsDevice device;

    const int number_of_vertices = 8;
    public const int number_of_indices = 36;

    public VertexBuffer vertices;
    public IndexBuffer indices;

    public Cube(GraphicsDevice graphicsDevice)
    {
        device = graphicsDevice;
    }

    public void CreateCubeVertexBuffer()
    {
        VertexPositionTexture[] cubeVertices = new VertexPositionTexture[number_of_vertices];

        "VERTICES HERE"

        vertices = new VertexBuffer(device, VertexPositionTexture.VertexDeclaration, number_of_vertices, BufferUsage.WriteOnly);
        vertices.SetData<VertexPositionTexture>(cubeVertices);
    }

    public void CreateCubeIndexBuffer()
    {
        UInt16[] cubeIndices = new UInt16[number_of_indices];

        "INDICES HERE"

        indices = new IndexBuffer(device, IndexElementSize.SixteenBits, number_of_indices, BufferUsage.WriteOnly);
        indices.SetData<UInt16>(cubeIndices);

    }

    public void Draw(BasicEffect effect)
    {

        foreach (EffectPass pass in effect.CurrentTechnique.Passes)
        {
            effect.CurrentTechnique.Passes[0].Apply();

            device.SetVertexBuffer(vertices);
            device.Indices = indices;

            device.DrawIndexedPrimitives(PrimitiveType.TriangleList, 0, 0, number_of_vertices, 0, number_of_indices / 3);
        }
    }
}
}

The error is at the line indices = new IndexBuffer(blah, blah, blah);

 

            cube = new Cube(device);
            cube.CreateCubeIndexBuffer();
            cube.CreateCubeVertexBuffer();
 
Thats how I'm creating my cube. The reason for this is that I only want the buffers to be called once within the game to reduce lag
Edited by burnt_casadilla

Share this post


Link to post
Share on other sites
Advertisement

Where do you call that ? If you do that in YourGame.LoadContent it should be fine (just checked).

 

Also: When reporting crashes, please show us the call stack (not everything usually a handful of frames is enough).

Edited by unbird

Share this post


Link to post
Share on other sites

It is in my load content but it doesnt work

 

System.NullReferenceException was unhandled
  Message=Object reference not set to an instance of an object.
  Source=Microsoft.Xna.Framework.Graphics
  StackTrace:
       at Microsoft.Xna.Framework.Graphics.VertexBuffer.CreateBuffer(VertexDeclaration vertexDeclaration, UInt32 dwVertexCount, UInt32 usage, _D3DPOOL pool)
       at Microsoft.Xna.Framework.Graphics.VertexBuffer..ctor(GraphicsDevice graphicsDevice, VertexDeclaration vertexDeclaration, Int32 vertexCount, BufferUsage usage)
       at Cube_Chaser.Cube.CreateCubeVertexBuffer() in C:\Users\daj\Documents\Visual Studio 2010\Projects\Cube Chaser\Cube Chaser\Cube Chaser\Cube.cs:line 37
       at Cube_Chaser.Cube..ctor(GraphicsDevice graphicsDevice) in C:\Users\daj\Documents\Visual Studio 2010\Projects\Cube Chaser\Cube Chaser\Cube Chaser\Cube.cs:line 117
       at Cube_Chaser.Game1.Initialize() in C:\Users\daj\Documents\Visual Studio 2010\Projects\Cube Chaser\Cube Chaser\Cube Chaser\Game1.cs:line 61
       at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
       at Microsoft.Xna.Framework.Game.Run()
       at Cube_Chaser.Program.Main(String[] args) in C:\Users\daj\Documents\Visual Studio 2010\Projects\Cube Chaser\Cube Chaser\Cube Chaser\Program.cs:line 15
  InnerException: 

Share this post


Link to post
Share on other sites
Well, from that call stack it rather looks it's called in Initialize and it's the vertex buffer creation that fails. Works fine for me here even in Initialize. Please show the code of the whole body of Initialize. Or create a minimal project which reproduces the problem and upload it here, I take a look.

Share this post


Link to post
Share on other sites
protected override void Initialize()
        {
            // TODO: Add your initialization logic here
            cube = new Cube(device);

            camera = new Camera(new Vector3(0.5f, 1.5f, 0.5f), 0, GraphicsDevice.Viewport.AspectRatio, 0.5f, 100f);
            effect = new BasicEffect(GraphicsDevice);
            cubes = new DrawableList<Cube>(this, camera, effect);
            device = GraphicsDevice;
            
            for (int x = 0; x < mapCoordsX; x++)
            {
                mapX[x] = x;
            }

            for (int z = 0; z < mapCoordsZ; z++)
            {
                mapZ[z] = z;
            }

            for (int y = 0; y < mapCoordsY; y++)
            {
                mapY[y] = y;
            }

            base.Initialize();
        }

        /// <summary>
        /// LoadContent will be called once per game and is the place to load
        /// all of your content.
        /// </summary>
        protected override void LoadContent()
        {
            cube.CreateCubeVertexBuffer();
            cube.CreateCubeIndexBuffer();
            // Create a new SpriteBatch, which can be used to draw textures.
            spriteBatch = new SpriteBatch(GraphicsDevice);
            font = Content.Load<SpriteFont>("font");
            grass = Content.Load<Texture2D>("grass");

            // TODO: use this.Content to load your game content here
            Components.Add(cubes);

            for (int x = 0; x < 50; x++)
            {
                for (int z = 0; z < 50; z++)
                {
                    cubes.Add(new Vector3(mapX[x], 0f, mapZ[z]), Matrix.Identity, grass);
                }
            }

            string mapString = reader.ReadToEnd();
        }

Here's both of the methods. Would it make sense to put the CreateBuffer methods in the constructor of the cube? 

 

"cubes" is a drawable list made up of cubes

Edited by burnt_casadilla

Share this post


Link to post
Share on other sites
Well, this is debugging 101. Your device = GraphicsDevice is happening after your cube = new Cube, so it is still null. Always look at the parameters in question if you have a crash.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement