Sign in to follow this  
SebSnake

OpenGL Enabled depth buffer creates white ghost object

Recommended Posts

SebSnake    101
Hi there,
 
I'm "learning" opengl for some days now and try to solve all the tutorials I can find on the web.
The first "hello triangle" took quite some time, but I already got my hands on some colored cube chapters by now.
 
And thats where I get my first unsolvable problem (at least by me). That's why I'm here, and I hope you can help me. 
 
--- The problem ---
When I enable the depth buffer, my code generates a strange "ghost" object after some seconds. When I disable the depth buffer, running the code won't generate it, but my cube looks wierd (because of the missing depth test).
I'm using glm for mathematics, GLEW 1.9 and GLFW 3.0.1.
For demonstration purposes, watch this short clip on youtube, to see my problem in action:
 
http://www.youtube.com/watch?v=TYKMR7lkp30
(Error shows up at 0:11)
 
--- The code ---
I know my code is not the best.
I have been coding .NET (C#) for years now and learn opengl and c++ now the "learning by doing" way for a week 
I try to shorten it to the important parts:
 
1) Setting up the window:
//GLFW
if(glfwInit() == GL_FALSE)
{
   cerr << "GLFW Init Error!";
   cin.ignore( numeric_limits<streamsize>::max(), '\n' );
   return 1;
}
 
//GLFW Hints
glfwWindowHint(GLFW_CONTEXT_VERSION_MAJOR, 4);
glfwWindowHint(GLFW_CONTEXT_VERSION_MINOR, 3);
glfwWindowHint(GLFW_OPENGL_PROFILE, GLFW_OPENGL_CORE_PROFILE);
glfwWindowHint(GLFW_OPENGL_FORWARD_COMPAT, GL_TRUE);
glfwWindowHint(GLFW_DEPTH_BITS,32);
 
//GLFW window
GLFWwindow* w = glfwCreateWindow(SCREEN_W, SCREEN_H, "Test 01", NULL, NULL);
glfwMakeContextCurrent(w);
 
//GLEW
glewExperimental = GL_TRUE; 
GLenum err = glewInit();
if(err != GLEW_OK)
{
   cerr << "GLEW Init Error: " << glewGetErrorString(err);
   cin.ignore( numeric_limits<streamsize>::max(), '\n' );
   return 1;
}
 
 
2) Creating the buffers and that stuff:
(The first two lines create a custom made "cube" object. The constructor takes X/Y/Z-coords in world space and the length of the cubes sides. The second line creates the vertices for the cube.)
//Cube
cuteCube = new cube(0,0,0,2);
cuteCube->createCubeVertices();
 
//Indices Buffer
glGenBuffers(1, ebo);
glBindBuffer(GL_ELEMENT_ARRAY_BUFFER, ebo[0]);
glBufferData(GL_ELEMENT_ARRAY_BUFFER, cuteCube->getVertexIndicesSize(), cuteCube->getVertexIndices(), GL_STATIC_DRAW);
 
//Vertex Arrays
glGenVertexArrays(1, vao);
glBindVertexArray(vao[0]);
 
//VBO Buffer
glGenBuffers(1, vbo);
glBindBuffer(GL_ARRAY_BUFFER, vbo[0]);
glBufferData(GL_ARRAY_BUFFER, cuteCube->getVertexPositionsSize() + cuteCube->getVertexColorsSize(), NULL, GL_STATIC_DRAW);
glBufferSubData(GL_ARRAY_BUFFER, 0, cuteCube->getVertexPositionsSize(), cuteCube->getVertexPositions());
glBufferSubData(GL_ARRAY_BUFFER, cuteCube->getVertexPositionsSize(), cuteCube->getVertexColorsSize(), cuteCube->getVertexColors());
 
shader_position = glGetAttribLocation(shader_program, "inPosition");
shader_color = glGetAttribLocation(shader_program, "inColor");
glVertexAttribPointer(shader_position, 4, GL_FLOAT, GL_FALSE, 0, (const GLvoid*)0);
glVertexAttribPointer(shader_color, 4, GL_FLOAT, GL_FALSE, 0, (const GLvoid*)cuteCube->getVertexPositionsSize());
glEnableVertexAttribArray(shader_position);
glEnableVertexAttribArray(shader_color);
 
glClearColor(1.0, 1.0, 1.0, 1.0);


//MVP stuff
shader_mvp = glGetUniformLocation(shader_program, "MVP");
glm::mat4 Projection = glm::perspective(45.0f, (float)SCREEN_W / (float)SCREEN_H, 0.1f, 100.0f);
glm::mat4 View = glm::lookAt(glm::vec3(4,3,-3), glm::vec3(0,0,0), glm::vec3(0,1,0));
glm::mat4 Model = glm::mat4(1.0f);
glm::mat4 MVP = Projection * View * Model;
 
 
3) The "render-loop":
while (!glfwWindowShouldClose(w))
{ 
   glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);
 
   //This line "enables" the bug
   glEnable(GL_DEPTH_TEST);
 
  
   glDepthFunc(GL_LESS);
   glUseProgram(shader_program);
 
   //setup uniform MVP
   glUniformMatrix4fv(shader_mvp, 1, GL_FALSE, &MVP[0][0]);
 
   glBindVertexArray(vao[0]);
   glBindBuffer(GL_ELEMENT_ARRAY_BUFFER, ebo[0]);
 
   glPolygonMode(GL_FRONT_AND_BACK, rendermode[render]);
   glDrawElements(GL_TRIANGLES, 36, GL_UNSIGNED_SHORT, NULL);
 
   glfwSwapBuffers(w);
   glfwPollEvents();
 
   //Update rotation
   Model = glm::rotate(Model,1.0f,glm::vec3(0,1,0));
   MVP = Projection * View * Model; 
}
 
 
4) The shaders.
4.1) Vertex shader:
#version 430 core
 
in vec4 inPosition;
in vec4 inColor;
 
out vec4 passColor;
 
uniform mat4 MVP;
 
void main()
{
   passColor = inColor;
   gl_Position = MVP * inPosition;
}
 
 
4.2) Fragment shader:
#version 430 core
 
in vec4 passColor;
out vec4 outColor;
 
void main()
{
   outColor = vec4(passColor[0], passColor[1], passColor[2], passColor[3]);
}
 
 
I am thankful for any suggestions.

Share this post


Link to post
Share on other sites
__SKYe    1784

Looking at that code, nothing strikes me as wrong...

 

Have you tried enabling back face culling, and making sure the cube's faces have the correct winding?

Share this post


Link to post
Share on other sites
apatriarca    2365

It looks like you are depth testing against a fixed cube. As if you have written on the depth buffer once and then used it over and over. Have you checked for errors and tried debugging it?

Edited by apatriarca

Share this post


Link to post
Share on other sites
SebSnake    101
Thanks for your answers. Unfortunately, I found the "bug" already - it is not within the code, it is my computer.
Tested the compiled exe on two other systems (one intel + nvidia, like my programming rig, and one amd+ati), both did not produce the glitch.
 
I checked my running processes. Do you know "Trillian", some IM app for multiple protocols? It has an "ingame-chat"-function. It detects running games and allows you to use a keybinding to open up a chat window ingame without ALT+TABing. So, when this feature detects the game (thats why it happens some seconds after it was run and not instantly), it creates this bug. Simply deactivated the ingame-chat-function in Trillian and tadaaa - problem solved.
 
Sorry for any inconveniences. 

Share this post


Link to post
Share on other sites
kunos    2254

sorry but that was my initial diagnosis... that looks like an hardware problem.. probably temperature related.. the code looked fine to me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • By povilaslt2
      Hello. I'm Programmer who is in search of 2D game project who preferably uses OpenGL and C++. You can see my projects in GitHub. Project genre doesn't matter (except MMO's :D).
    • By ZeldaFan555
      Hello, My name is Matt. I am a programmer. I mostly use Java, but can use C++ and various other languages. I'm looking for someone to partner up with for random projects, preferably using OpenGL, though I'd be open to just about anything. If you're interested you can contact me on Skype or on here, thank you!
      Skype: Mangodoor408
    • By tyhender
      Hello, my name is Mark. I'm hobby programmer. 
      So recently,I thought that it's good idea to find people to create a full 3D engine. I'm looking for people experienced in scripting 3D shaders and implementing physics into engine(game)(we are going to use the React physics engine). 
      And,ye,no money =D I'm just looking for hobbyists that will be proud of their work. If engine(or game) will have financial succes,well,then maybe =D
      Sorry for late replies.
      I mostly give more information when people PM me,but this post is REALLY short,even for me =D
      So here's few more points:
      Engine will use openGL and SDL for graphics. It will use React3D physics library for physics simulation. Engine(most probably,atleast for the first part) won't have graphical fron-end,it will be a framework . I think final engine should be enough to set up an FPS in a couple of minutes. A bit about my self:
      I've been programming for 7 years total. I learned very slowly it as "secondary interesting thing" for like 3 years, but then began to script more seriously.  My primary language is C++,which we are going to use for the engine. Yes,I did 3D graphics with physics simulation before. No, my portfolio isn't very impressive. I'm working on that No,I wasn't employed officially. If anybody need to know more PM me. 
       
    • By Zaphyk
      I am developing my engine using the OpenGL 3.3 compatibility profile. It runs as expected on my NVIDIA card and on my Intel Card however when I tried it on an AMD setup it ran 3 times worse than on the other setups. Could this be a AMD driver thing or is this probably a problem with my OGL code? Could a different code standard create such bad performance?
    • By Kjell Andersson
      I'm trying to get some legacy OpenGL code to run with a shader pipeline,
      The legacy code uses glVertexPointer(), glColorPointer(), glNormalPointer() and glTexCoordPointer() to supply the vertex information.
      I know that it should be using setVertexAttribPointer() etc to clearly define the layout but that is not an option right now since the legacy code can't be modified to that extent.
      I've got a version 330 vertex shader to somewhat work:
      #version 330 uniform mat4 osg_ModelViewProjectionMatrix; uniform mat4 osg_ModelViewMatrix; layout(location = 0) in vec4 Vertex; layout(location = 2) in vec4 Normal; // Velocity layout(location = 3) in vec3 TexCoord; // TODO: is this the right layout location? out VertexData { vec4 color; vec3 velocity; float size; } VertexOut; void main(void) { vec4 p0 = Vertex; vec4 p1 = Vertex + vec4(Normal.x, Normal.y, Normal.z, 0.0f); vec3 velocity = (osg_ModelViewProjectionMatrix * p1 - osg_ModelViewProjectionMatrix * p0).xyz; VertexOut.velocity = velocity; VertexOut.size = TexCoord.y; gl_Position = osg_ModelViewMatrix * Vertex; } What works is the Vertex and Normal information that the legacy C++ OpenGL code seem to provide in layout location 0 and 2. This is fine.
      What I'm not getting to work is the TexCoord information that is supplied by a glTexCoordPointer() call in C++.
      Question:
      What layout location is the old standard pipeline using for glTexCoordPointer()? Or is this undefined?
       
      Side note: I'm trying to get an OpenSceneGraph 3.4.0 particle system to use custom vertex, geometry and fragment shaders for rendering the particles.
  • Popular Now