• Advertisement
Sign in to follow this  

Eclipse keeps saying "Re-indexing (fully) repository <username here>"

This topic is 1727 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ok, I've looked at several resources to try to help me fix this issue, but none help! I asked on StackExchange and it got closed. I saw a few questions on StackExchange about this, but none helped. Here are the resources I found(none I found helped):

 

https://bugs.eclipse.org/bugs/show_bug.cgi?id=376270

http://stackoverflow.com/questions/16313851/re-indexing-repository-loop-not-maven

http://stackoverflow.com/questions/17559541/eclipse-keeps-reindexing-and-wont-stop

 

I looked at more, but I couldn't find them again. If I do I'll edit the post.

 

The issue occurs when I edit a file and save it, paste a new file in or edit ANYTHING in Eclipse in any way. It stopped for an hour, then started again.

 

The issue causes my MacBook Pro to heat up like crazy, slow down and it becomes impossible to hold or touch due to the heat of it(yes, it gets that bad, and it only takes 10 minutes of that to happen), and I need to force restart my machine by holding down the power off button.

 

Any other information that would be necessary will be provided upon request.

 

In case it wasn't obvious, I need to know how to stop this issue.

 

I've went into:

 

Preferences -> Team -> Git

 

and disabled every option I could see(and applied it, of course).

 

I've tried uninstalling and reinstalling Eclipse 5 times and it's done NOTHING.

 

So yeah, please help! I can't find a way to fix this issue!!!!!! :( :( :(

 

SCREENSHOT:

 

hl63jy3.jpg

 

Thanks! Any help is appreciated!

Share this post


Link to post
Share on other sites
Advertisement

Firstly, just to rule out a wider problem, have you noticed similar symptoms when running any other software?

 

I'm not familiar with Eclipse, but...

 

Are you (intentionally) using source control?

Do you have any plug-ins installed?

 

 

Also, looking at your question on StackExchange, it looks like they would probably be happy to re-open it for further responses if you were able to edit it to be clearer and more specific.  You should include the version of Eclipse you're using, whether or not any plug-ins are installed, and a more complete list of actions that cause the problem to occur.  Put your actual problem at the start of your question, and then briefly mention at the bottom that you tried the suggestions from the similar question with no luck, and that you believe your problem may be different to the other.

 

smile.png

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement