Jump to content
  • Advertisement
Sign in to follow this  
cozzie

Stupid directinput question...

This topic is 2180 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

When I startup my app (3d engine demo) and move the mouse during loading of the scene etc., the cursor movement is 'tracked' and affects the starting position of my camera )-;

 

In backups of my code and earlier demo's, I didn't have this.

 

Anyone have any idea where to look?

I've tried playing around with the exclusive modes/ foreground/ background, but no luck..

 

Share this post


Link to post
Share on other sites
Advertisement

Got it.

I was loading a 6MB audio file in my main function (for testing), and somehow the application already executed the message loop, updating the mouse position.

When I move the loading of the audio to my SetupEngine function (called at first within main) the problem is gone.

 

Not sure if I understand why/ how it works like this though

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!