Sign in to follow this  
IrYoKu1

DXUT and Windows 8, application hanging on first run

Recommended Posts

Hi,

 

I'm having troubles with old DXUT-based demos in my new Windows 8 system (I believe that is the cause, still not sure).

 

It seems the first time they are run, they hang for about one minute or two. Subsequent runs are fine. But if I change the executable file name or move them around the filesystem, then they will hang again the first run (so it seems to be something related with the path; note that I've the antivirus turned off).

 

This didn't happened to me before, so it seems it's either a problem with Windows 8 and DXUT, or with my system (I've tried it on a system with the same GPU and drivers but with Windows 7, and no problems).

 

The same happens with any DX SDK sample that is using DXUT. In particular, one of my projects that are having this problem is this one:

Code: https://github.com/iryoku/smaa/zipball/v2.8

Binary: http://iryoku.com/smaa/downloads/SMAA-DX10-v2.8.exe

 

If someone can also test this in Windows 8, and see if it hangs as well I'd really appreciate it (just to know if it's a Windows 8 problem, or something specific to my machine).

 

Thanks!
Jorge

 

Edited by IrYoKu1

Share this post


Link to post
Share on other sites

I observe the same issue on my system. On the first run it hangs for some time. But not one or two minutes more like 15 - 20 seconds. After second try it loads with a delay of 3-5 seconds. When I renamed the exe the application begins to hang on the "first run" for 15 - 20 seconds.

 

I haven't looked at the code but I think its an issue with windows 8.

 

Specs:

Windows 8 Pro x64

Pentium Dual Core @ 3,4 GHz

NVIDIA 640GT

6 GB RAM

Share this post


Link to post
Share on other sites

No hangs here too, the demo runs in 2-3 seconds (shader compilation at runtime) after lunching it.

Windows 8 X64 Pro

i5 750 @ 3.360

AMD Radeon 6970

16GB RAM

 

Try some profiling tools (like amd gpu perf studio 2, works on geforce cards too).

Edited by Alessio1989

Share this post


Link to post
Share on other sites

So, it's certainly not a Windows 8 problem, but likely to be a Windows 8 + something else, as only Megamoscha could repo it. I was thinking it was an AMD issue, but seems no to be the case. The weird thing is that this not specific to my applications, but also happen to all DX SDK samples using DXUT.

 

I'm not sure it could be the shader compilation, the whole system became very unresponsive in my case (to the point I've just to sit and wait for it to finish), and CPU utilization is about 16% (a single thread). I think it's something going on in the GPU. For what I debugged past week, it seems to hang in a EnumDisplayDevices loop.

 

Many thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this