Archived

This topic is now archived and is closed to further replies.

unresolved external symbol ___glutInitWithExit@12... HELP!!

This topic is 5927 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Linking... main.obj : error LNK2001: unresolved external symbol ___glutInitWithExit@12 main.obj : error LNK2001: unresolved external symbol ___glutCreateWindowWithExit@8 Debug/solarsystem.exe : fatal error LNK1120: 2 unresolved externals Someone tell me how to fix that.. I have opengl32.lib glut32.lib and glu32.lib linked to my project (Im using MSVC6.0).. anyone have advice?

Share this post


Link to post
Share on other sites
This might mean that your glut32.lib and glut.h versions don't match.

Version 4 (I think) of the glut header changes glutInit to glutInitWithExit on Win32 systems, to get around a bug. If your glut32.lib is from an earlier version that doesn't have this bugfix, then you'll get that message. You either want to install an old version of glut.h, or a new version of glut32.lib and glut32.dll. I'd go for the new version if possible.

Uuuuuulrika-ka-ka-ka-ka-ka

[Typo fix]

Edited by - Mayrel on October 25, 2001 3:11:16 PM

Share this post


Link to post
Share on other sites
Wow thanks!

I just realized that every time I created a new project/workspace, I would copy and paste a version of Glut32.lib that was really old, and never knew. Until you said something just now, I replaced all of those old files with the new glut32.lib.. And it all works..

Thanks! Youll have to excuse my newbie opengl-ish-ness..

~zeus

Share this post


Link to post
Share on other sites