Jump to content
  • Advertisement
Sign in to follow this  

Crashes upon device creation

This topic is 2140 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a problem with creating a D3D11 device. On one computer which has long been not formatted (probably a lot of libs and stuff like that installed) my app works fine. On another computer, which is a clean Win7 x64 installation, I compiled my app and it crashes upon device creation, that is, D3D11CreateDevice returns a null pointer to the device. I've already updated my Windows with various updates etc. but that has not helped. Any idea?


I remember I had the same problem on another computer when I tried to create the device with D3D11_CREATE_DEVICE_DEBUG flag. Without this flag it was all fine. But now it crashes no matter whether this flag is on or off.



I've just updated Windows 8 SDK and the device creation process goes fine. Now, when I try to run my app via F5 key (Debug mode) it crashes upon swap chain creation. But, when I run the build with DEBUG -> Graphics -> Start Diagnostics (Alt + F5) everything is fine. Any idea why "regular" F5 doesn't work?

Edited by maxest

Share this post

Link to post
Share on other sites
Sign in to follow this  

  • Advertisement

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!