Jump to content
  • Advertisement
Sign in to follow this  
Migi0027

DX11 DX11 - Loading large scenes - GPU Hangs

This topic is 2119 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys! wink.png

 

Just a quick question.

 

After loading the Sponza Scene, with ALL textures and all meshes, the system hangs for 2-4 seconds (Can't move anything, could be the GPU hanging as it is processing all the stuff, maybe caching?), what could be the cause of this, and this is only when the first frame starts.

 

Thanks, as usual.

-MIGI0027

Share this post


Link to post
Share on other sites
Advertisement


After loading the Sponza Scene, with ALL textures and all meshes, the system hangs for 2-4 seconds (Can't move anything, could be the GPU hanging as it is processing all the stuff, maybe caching?), what could be the cause of this, and this is only when the first frame starts.

 

Set breakpoints and step through your code to see where it hangs. If there is no single point where it hangs for more than 1 seconds, its the amount of textures and meshes that need to be processed - if you e.g. load the meshes in a human readable format and not binary, it can take quite some time. Also try hitting F12 while running in the debugger and while it hangs, this will jump you to the code-point where the application currently is at - if nothig happens (don't know if this is works only for visual studio though), there is some external hang like on the GPU.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!