Jump to content
  • Advertisement
Sign in to follow this  
jack872

Grey triangles (DX9)

This topic is 2108 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hello guys,

I'm writing a game using DirectX9, I've always used my new pc (with a nvidia graphic card) to write the code and I hadn't any problem until I moved the code/binaries to my old computer with a ATI Radeon HD 4870:

 

2vbmzxw.png

 

It doesn't even render the world, all you can see is just these grey triangles.

At the beginning I thought they were driver issues but then I relaized they were not (I updated them). The code is huge as it is a 3D game and since I'm debugging it for about a week without finding the problem, I'd like some suggestions. what can it be caused to? when does this happen?

please, I need to fix this as soon as possibile.

Share this post


Link to post
Share on other sites
Advertisement

Try debugging it with Pix and see if valid data is sent to the GPU. It really helps!

 

That's all for now. *Still thinking about other issues for you*.

 

-MIGI0027

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!