Jump to content
  • Advertisement
Sign in to follow this  
Poo Bear

DX11 windows8.1 disables part of DirectX control panel?

This topic is 1614 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

I have to maintain some old D3D9 code and I have to use a windows8.1 machine to do it, everything compiles and runs, but I need the debug runtime activating to search down some issues. However, it's been greyed out - eek!

 

 

 

mpNVf.png

 

 

I did find some posts referring to a fix for this: "Using regedit, go to key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Direct3D. The "Trusted Installer" has ownership of this key. Change ownership to Administrators, then grant "Full Access" to the Administrators. Now run the DX Control Panel (as admin, of course). Now the changes should be saved."

 

Problem is I can't find Direct3D in the registry? I've got DirectDraw/Input/Music/Play/Show/X/XSDK, but no Direct3D.

 

Anybody got any ideas how to activate the debug runtime? I know the obvious ones are either go back to win7 or upgrade all the code DX11, but sadly neither of those options are practical.

 

 

thanks...

 

Share this post


Link to post
Share on other sites
Advertisement


I did find some posts referring to a fix for this: "Using regedit, go to key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Direct3D. The "Trusted Installer" has ownership of this key. Change ownership to Administrators, then grant "Full Access" to the Administrators. Now run the DX Control Panel (as admin, of course). Now the changes should be saved."

LOL... thanks for citing me.

Is this new in 8.1; I mean, was the key present in Windows 8.0?

Share this post


Link to post
Share on other sites

I don't know, never had win8.0, I've been hanging onto win7 as long as I can, but everything just got updated straight to 8.1 at the office so I'm a bit stuffed.

Share this post


Link to post
Share on other sites

Yes, there is a Direct3D key in there - woo!. However, I can't follow the original fix, as permissions work differently in win8.1 than in win7 so not really sure what to do. 

 

:(

Share this post


Link to post
Share on other sites

Setting the keys in the registry under Wow6432Node to 1 do change some settings in the 32-bit Direct3D 9 control panel. It does however not enable debugging or remove the gray-out, that must be controlled by something else.

Share this post


Link to post
Share on other sites

Debug runtime of the "old legacy" DirectX SDK (2010 and prior)  don't work on Windows 8/8.1 and even on windows 7 SP1 with Platform update as far as I know. This is why PIX don't works on those platforms.

 

If you want debug dx9 code, you need a machine With Windows 7 (without the platform update) or a previous OS.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!