Jump to content
  • Advertisement
Sign in to follow this  
codeman_nz

OpenGL Help with Glut in Dev-C++

This topic is 1723 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am losing my mind here.  I just downloaded the glut devpak and created a new project using the glut template but I get errors like this:

[Linker Error] undefined reference to `_imp____glutInitWithExit@12'

 

I know this is linker error and I need to link the glut library but I have already done that like this:

-lglut32 -lglu32 -lopengl32 -lwinmm -lgdi32

 

But I still get that error and I have no idea how to fix it.

Share this post


Link to post
Share on other sites
Advertisement

Did you down load into the Dev C++ folder ?

 

Verify where it is on the Disk Drive and make Certain that folder location is referenced in your Project Settings

Share this post


Link to post
Share on other sites
If the linker only complains about the WithExit-functions, then it is probably the "atexit-hack". You can disable it with #define GLUT_DISABLE_ATEXIT_HACK before including the GLUT header.

Share this post


Link to post
Share on other sites

Yes I downloaded into the dev c++ folder.

 

I am using wxDev-c++ running on windows 7

 

I downloaded the devpak from the devpak website and I think it is up to date.

 

No that is not the only one.  It is coming back with a whole lot of errors.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!