Jump to content
  • Advertisement
Sign in to follow this  
proanim

vs2013 requires entry point on library

This topic is 2080 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to compile converted project from vs2008 in vs2013, needless to say it needs fixes in places. The project is not mine, but i could convert it to vs2010 and vs2012 more or less without problems. But now when I try to compile the thing it gives 

 

FXC : error X3501: 'main': entrypoint not found

 

when compiling static library. In project settings it is specified that it should be creating lib file, and i had to manually setup build type to x86 and windows since it wasn't converted from previous version.

 

Why is this occurring? I don't have any idea how to fix it, and i am sure that the code is good as it is since it is in working condition.

Share this post


Link to post
Share on other sites
Advertisement

This is about your shadercode. VS2013 tries to compile your shader files into .cso files, if you dont want that to happen, exclude the shader files from build via the properties page.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!