Jump to content
  • Advertisement
Sign in to follow this  
b1gjo3

Trouble building GTK+ on OSX 10.8

This topic is 2074 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello GameDev

 

I'm having some issues building my dev environment for GTK+ in OSX 10.8. I have followed the instructions from https://wiki.gnome.org/GTK+/OSX/Building but when I get to the part where it says to run command:

 

jhbuild bootstrap

 

I get the following error everytime.

[ 40%] Built target LIBCURL
In file included from /System/Library/Frameworks/CoreServices.framework/Frameworks/AE.framework/Headers/AE.h:20,
                 from /System/Library/Frameworks/CoreServices.framework/Headers/CoreServices.h:18,
                 from /Users/[redacted]/gtk/source/cmake-2.8.9/Utilities/cmlibarchive/libarchive/archive_string.c:65:
/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/CarbonCore.h:176:32: error: CarbonCore/Folders.h: No such file or directory
make[2]: *** [Utilities/cmlibarchive/libarchive/CMakeFiles/cmlibarchive.dir/archive_string.c.o] Error 1
make[1]: *** [Utilities/cmlibarchive/libarchive/CMakeFiles/cmlibarchive.dir/all] Error 2make: *** [all] Error 2
*** Error during phase build of cmake: ########## Error running make -j 9 *** [3/19]

  [1] Rerun phase build
  [2] Ignore error and continue to install
  [3] Give up on module
  [4] Start shell
  [5] Reload configuration
  [6] Go to phase "wipe directory and start over"
  [7] Go to phase "configure"
  [8] Go to phase "clean"
  [9] Go to phase "distclean"
choice:

I have the latest version of XCode installed and made sure that my /Developer directory points to XCode.app/Contents/Directory. I have uninstalled MacPorts as suggested from their website. I have been troubleshooting myself the last couple days on/off and have nowhere else to turn to but you guys. I know it's probably a simple fix but I can't wrap my head around it.

 

Any thoughts/ideas would be greatly appreciated.

 

Thanks

 

edit:

 

It looks as if I've found the problem... but I still don't know how to fix it. It's the same problem this guy was having in this thread: http://stackoverflow.com/questions/5440300/gcc-include-path-and-symlinks/5440502#5440502. It looks like the compiler is able to see and begin processing CarbonCore.h (which is in the same dir as Folders.h).

/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/CarbonCore.h:176:32: 
error: CarbonCore/Folders.h: No such file or directory

I tried going in and editing CarbonCore.h line 176 to but this doesn't work either. I have tried to make a symbolic link several different ways but it's not working. Anybody know what I can do to fix this?

#include <CarbonCore.framework/Folders.h>
Edited by sc2bigjoe

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!