Jump to content
  • Advertisement
Sign in to follow this  
Stavros Dimou

A little help with Blender 2.6 ?

This topic is 2158 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello,I'm not a 3d modeller but in fact I try to build up a game doing everything else than creating its 3d models and composing its music.

But as I get 3d models from people to use in the game I work on,I often (most of the times) have to do some editing in order to get the model  working correctly in the game,so I must use Blender anyway. And most often I have to create textures and wrap them on the 3d models.

The problem I have is showing up during the texture creation workflow.

 

So here is the complete list of what I do step by step,and what happens:

 

#1 Model is in 3ds format,so I import a 3ds file.

#2 I decimate or subdivide the model,to bring it to the ideal polygon count.

#3 I unwrap the UV map and generate a .png file of the UV.

#4 I save the .png image.

#5 I save the working project as a 3ds file as it was.

#6 I close Blender. (Because my computer isn't that much powerful to run Blender with a model loaded,and the image editing program at the same time)

#7 I open the image editor and create the texture,I save it as .png

#8 I open Blender,and load the new decimated or subdivided 3ds file.

#9 The 3ds file is so tiny I initially thought it didn't loaded.

 

 

You see,the problem shows up at step #9. When I load the 3d model the second time when I have the texture ready,the model will show up extremely tiny,barely 4 to 5 pixels on a 1080p monitor. Why is this happening ? I didn't even touched the Transform controls before saving the file. Why its Scale change without me telling it to change ?

With the model only being like from 3 to 5 pixels on the screen at the maximum zoom level Blender has,my mouse pointer can barely touch it,and if it does,it selects individual parts of the mesh,and not all of it,so trying to manually scale it up to the original size messes the mesh terribly.

 

Please tell me,am I missing something ??

Is there a way to prevent the model getting minimized ?

Edited by Stavros Dimou

Share this post


Link to post
Share on other sites
Advertisement

Thank you very much for your help! :D

Not using the 3ds format fixed it! I just saved the file as .blend and it worked! It also loaded in Unity textured natively,which is great.

@BloodyEpi: I did what you wrote,but this made the mesh huge!

Share this post


Link to post
Share on other sites

In the future you could use the .obj format. It has less issues (3ds does give me woes sometimes). But if you want to use 3ds you should check the export options and see if there is anything there that is making it shrink. 

Edited by Tutorial Doctor

Share this post


Link to post
Share on other sites

Some tips that might help you:

 

- Use .blend, because Unity is able to open it (internally converts it to .fbx in case anyone is wondering). The .obj format is worse than .blend because it doesn't support animations among other things. If you can't use .blend, export to .fbx especially with Unity. Always keep the native .blend file of your model because it's best for editing further in Blender.

- You can select/deselect all objects in the scene (or all the vertices of the mesh if in edit mode) with A key. For selecting tiny objects you can also use B or C key selection modes in edit mode or in object mode you can use the Outliner panel (defaults on the top right) that shows a list of your objects. 

- Decimate is mainly good for quickly lowering polycount of terrain objects. It destroys the quad flow and making sense of the model will be very hard after you use it. Also it generates some inconsistencies when used aggressively. When you need to lower polycount and keep the quality and ability to edit you should mostly just manually remake the model possibly using some helpful modifiers as shrinkwrap

- Use subdivide sparingly and with consideration as it quickly multiplies your polycount and makes unnecessary subdivisions

Share this post


Link to post
Share on other sites

If you want an fbx file (forgot Unity handles these) use Autodesk FBX:

 

http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=20481519

 

It converts from 3ds, obj or collada to fbx. And it is free!

 

You can export .fbx directly from Blender and that's what you should do. Saving 3ds, obj or collada possibly breaks your file / loses information and converting won't help you anymore after that.

Share this post


Link to post
Share on other sites

When exporting from Blender, always immediately re-import it to see if anything has been corrupted.  Import/export is probably the weakest aspect of Blender right now so far as game developers are concerned.

 

If you are running in to scaling problems once exported to Unity check this out.  There is a scaling factor that is applied once your model is imported.  Keep in mind your units and Unitys might be really out of wack and can be fixed this way.

Share this post


Link to post
Share on other sites

Yeah, when I used Unity, I found that the Autodesk FBX software doesn't give as many errors as using Blender's export. I also used it for Google Sketchup models. 

Edited by Tutorial Doctor

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!