Jump to content
  • Advertisement
Sign in to follow this  
yahastu

DX11 D3DX in Visual Studio 2010 on Windows 7...

This topic is 1728 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Why use D3DX?

I understand that D3DX is deprecated and replaced by DirectXMath in the Windows 8 SDK.  However DirectXMath is not included in the Windows 7 SDK, and neither is D3DX...which means that there seems to be no "proper way" to access these basic utility functions.  I have heard that it may work to use the Windows 8 SDK for development on Windows 7, however, that doesn't sound entirely reliable to me...and I'm not interested in developing Windows 8 apps at this time anyway.  I would like to utilize some of my older code that is written using D3DX for this project and so I prefer to stick with that for now.  Therefore, I am trying to use the last DirectX SDK frome June 2010.

What's the problem?

After installing the DirectX SDK, and added the new include and lib paths under the Win32.User properties page in Visual Studio (as explained in the answer here ), and add the following includes:

 

#include <d3d11.h>
#include <d3dx11.h>
#include <d3dx10.h>

 

#pragma comment (lib, "d3d11.lib")
#pragma comment (lib, "d3dx11.lib")
#pragma comment (lib, "d3dx10.lib")

 

...and now, although I can use certain D3DX functions like D3DXCOLOR,  I get unresolved external symbol errors for certain functions like D3DXCompileFromFile and D3D11CreateDeviceAndSwapChain. 

I think the problem is that d3dx11.h exists in two places:
 

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Include
C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)\Include
 

In other words, the D3DX headers conflicts with the headers already present in the built in windows SDK, and I cannot even remove those built in include paths or give my include path priority over them (at least I don't know how).

How can I resolve this issue?

Edited by yahastu

Share this post


Link to post
Share on other sites
Advertisement

You can probably resolve this if you include the absolute path to both the D3DX header and library files (as a project's "Additional Dependencies").

 

#include <C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)\Include\d3dx11.h>

Share this post


Link to post
Share on other sites

You can probably resolve this if you include the absolute path to both the D3DX header and library files (as a project's "Additional Dependencies").

 

#include <C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)\Include\d3dx11.h>

I tried adding the paths to "Configuration Properties => C/C++ => General => Additional Include directories" and "Configuration Properties => Linker => General => Additional Library directories" (in addition to the Microsoft.Cpp.Win32.user properties), and also changed the include files to specify the full-path location to the D3DX headers as in your example, but there is no change.

Perhaps the problem lies with the fact that I cannot use an absolute path to specify the library name -- eg, in "#pragma comment (lib, "d3d11.lib")" and so, it may continue to look for the library in the Windows 7 sdk first....

It seems like this would be a problem for all Windows 7 users that attempt to use DirectX...there must be a common resolution

Share this post


Link to post
Share on other sites

I have heard that it may work to use the Windows 8 SDK for development on Windows 7, however, that doesn't sound entirely reliable to me...and I'm not interested in developing Windows 8 apps at this time anyway. 

It's fine, I've done it myself. The Windows SDK is set up such that you can specify the minimum supported Windows version at compile-time using macro definitions. If you specify that Windows 7 is your minimum version, then any unsupported functionality will be unavailable and you'll get a compilation error if you try to use it.

However you should still be able to get D3DX to work fine. You just need to make sure that the DX SDK directory is listed before the Windows SDK directory in your VC++ include directories. You can do this in the project settings by putting the DX SDK directory before the "inherited from project defaults" entry.

Share this post


Link to post
Share on other sites

Got it working.  The trick was modifying the list of semicolon delimitted items manually rather than via clicking on it and using the built-in path list editor.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!