Archived

This topic is now archived and is closed to further replies.

Clipper Doesn't Work on Top, Left edges of Window!

This topic is 5893 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm running out of ideas, and would really like to know if anyone has any idea what may be causing a clipper to work fine as an image leaves the right, and bottom edges of a screen, but are "cut away" as they leave the left or top edges. This is DirectDraw in a window. Currently, two clippers are being used, the primary surface has one attached to the main window handle (via SetHWnd), the secondary surface has one attached to a smaller region of the window to compensate for a black "border" between the edge of the actual window, and the viewable game area, somewhat akin to (32,32,windowwidth-32,windowheight-32) All objects entering and leaving the right, and bottom edges of the window clip properly. All objects entering and leaving the top and left edges are cut away and do not clip smoothly. I'm losing my mind here. Any tips on how to solve this, or possibly example code would really be appreciated. If anyone has any source to a windowed version of Asteroids, that's *exactly* the effect I am looking for and could really use a peek at your code. I'll provide source or the malfunctioning .exe on request. - Hanzo Edited by - Hanzo on October 29, 2001 12:38:42 AM

Share this post


Link to post
Share on other sites