Bit mask math

Started by
11 comments, last by Brother Bob 10 years, 2 months ago

How can I combine this into one statement?

I tried this but no luck

if(id &= ~(NX::COLLISION_ID_IsPickable | NX::COLLISION_ID_IsHighlightable) == 200)

//do something

irr::s32 id = selectedNode->getID();
if(id &= ~NX::COLLISION_ID_IsPickable)
if(id &= ~NX::COLLISION_ID_IsHighlightable)
if(id == 200)
{
//do something
}
Advertisement

if((id &= ~(NX::COLLISION_ID_IsPickable | NX::COLLISION_ID_IsHighlightable)) == 200)

sigh fat fingered my ()

now it works

... why do you want to write such a monstrosity? Clarity is way more important than conciseness. Split it up and simplify it. The assignment operation inside a condition is pretty scary. The magic number "200" is terrifying (it's mildly more clear if the hex 0xC8 is used but a named constant would be _strongly_ preferable).

Sean Middleditch – Game Systems Engineer – Join my team!

Surely this is more readable?!:


id &= ~(NX::COLLISION_ID_IsPickable | NX::COLLISION_ID_IsHighlightable);
if (id == 200)
"In order to understand recursion, you must first understand recursion."
My website dedicated to sorting algorithms

To elaborate on Sean's, I have to admit I have bought myself quite some peace of mind since I've restricted bitmask usage to serialization only. Just use structs.


auto props = selectedNode->getFlags();
if(props.canPick && props.canHilight) {
//do something
}

The profiler will tell you if code is hot or cold. Cold code has no point in not having maintainance and readability as priorities. Even if the code is hot, I would be careful in considering this an optimization.

Previously "Krohm"

C++ wizardry like that drives me nuts, and is a clear sign of an inexperienced programmer. SeanMiddleditch is totally right.
Clarity always wins over a couple of cycles worth of optimization, especially in a team environment where you aren't the only one dealing with the code. Basically, if you're trying to reduce line counts for arbitrary reasons, then you're doing it wrong. Bit masking and bit shifting is almost always a sign of over-complication.

visualnovelty.com - Novelty - Visual novel maker


I've programmed C++ for nearly 10 years and I have no idea what "id &= ~NX::COLLISION_ID_IsPickable" even does. (I do, but I'd have to look it up to be sure.)

Well, you must not have done a whole lot of bit manipulations in your 10 years of C++. In any case, a helper function can add clarity to the code, so I would do something like this:

void clear_bits(irr::s32 &x, irr::s32 bits_to_erase) {
  x &= ~bits_to_erase;
}
 
//...
clear_bits(id, NX::COLLISION_ID_IsPickable);

Bit fields might also help in this situation, since you can retain the packed nature of having bit-based data but instead accessing the data as C++ struct members for clarity.

Bit fields might also help in this situation, since you can retain the packed nature of having bit-based data but instead accessing the data as C++ struct members for clarity.

One annoying detail to keep in mind: the order in which bits are assigned is not defined. Not an issue if everything is happening on one machine and within the same application.

Still, not knowing if setting a particular field will effectively result in 0x01 or in 0x80 is always making me nervous.

f@dzhttp://festini.device-zero.de
Álvaro nice function. Like that...

The 200 isn't a permanent thing, it was more of a hurry up and post it!

I am using irrlicht and the id is a unsigned int and they are bit masking with the pipe | to do collision detection. So I am looking for ways to set and clear and change them without much headache...

Thanks!

This topic is closed to new replies.

Advertisement