Advertisement Jump to content
Sign in to follow this  
Seabolt

[ANDROID NATIVE ACTIVITY] Resume message is followed by window destruction

This topic is 1796 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey guys,

 

For some reason on a Nexus 7 device, I'll occasionally get a resume command and then at some after or during the command, I'll get a window destroyed command. This is an issue because I need to flag that it's safe to render again after the resume command, but then the device is killed.

 

Is this supposed to happen, am I not releasing correctly, or should I be handling the resume command differently?

 

I'm working on a project with a tight NDA so I can't say much, but please give me any ideas you might have.

Share this post


Link to post
Share on other sites
Advertisement

Hm... it's possible. I'm using native activity, so I'm not using any intents but I might be causing something similar when resuming.

 

Currently I can reproduce the issue by sleeping the screen and waking it up. I'm already releasing opengl resources and recreating them, and it will pause and resume correctly 90% of the time. 

 

Here's some of the output I get prior to the crash:

 

D/audio_hw_primary(  180): adev_set_parameters: exit with code(-2)
V/threaded_app( 8167): Resume: 0x728fae18
V/threaded_app( 8167): activityState=11
I/ACE     ( 8167): [ENGINE] Received Command 11...
I/ACE     ( 8167): [ENGINE] Command APP_CMD_RESUME
D/SurfaceControl(  526): Excessive delay in unblankDisplay() while turning screen on: 241ms
E/BufferQueue(  177): [com.ace.engine/android.app.NativeActivity] dequeueBuffer: BufferQueue has been abandoned!
W/Adreno200-EGLSUB( 8167): <DequeueBuffer:544>: dequeue native buffer fail: No such device
W/Adreno200-ES20( 8167): <gl2_surface_swap:43>: GL_OUT_OF_MEMORY
W/Adreno200-EGL( 8167): <qeglDrvAPI_eglSwapBuffers:3518>: EGL_BAD_ALLOC
W/Adreno200-EGL( 8167): <qeglDrvAPI_eglSwapBuffers:3525>: EGL_BAD_SURFACE
V/threaded_app( 8167): NativeWindowDestroyed: 0x728fae18 -- 0x730334e0
 
All the ACE tags are my application.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!