Sign in to follow this  

Sky in Deferred Shading & Light Pre-Pass

This topic is 1398 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello! I would like to add a sky to my deferred shading and light pre-pass renderers.  I already have a working skybox in my forward renderer. How would I do this? Is there some sort of post process sky technique I could try? Thanks! smile.png

Edited by KoldGames

Share this post


Link to post
Share on other sites

After combining the lighting buffer and the deferred buffers in our light pre-pass renderer into the target buffer, I just render the skydome into the same buffer afterwards. The same goes for transparent objects.

 

Cheers,

Henning

www.heroesandgenerals.com

Share this post


Link to post
Share on other sites

Hello! So I've been working on it and managed to get the skybox into the color buffer, but nothing is showing up in the final image.  The only way I could get the skybox to show up in the color buffer was by rendering the skybox before I everything.

b8n4.png

 

Here is a link to my deferred shading code:

 

NXRTDeferredShading.h

NXRTDeferredShading.cpp

 

Also, a link to my skybox code:
 

NXSkybox.h

NXSkybox.cpp

 

Also, your game looks pretty awesome.  I'm definitely going to try it out. Anyways, thanks for your time, I really appreciate it. :)

Share this post


Link to post
Share on other sites

Hello! So I've been working on it and managed to get the skybox into the color buffer, but nothing is showing up in the final image.

The sky does not go into the color buffer and that is not what he said to do.
Draw the color buffer without the sky, combine all the buffers, then add the sky afterwards.


L. Spiro

Share this post


Link to post
Share on other sites

The sky does not go into the color buffer and that is not what he said to do.
Draw the color buffer without the sky, combine all the buffers, then add the sky afterwards.

 

Hey! Sorry, I seem to be lacking a little attention to detail today. Haha, anyways, I believe I've now done what he has said.

void NXRTDeferredShading::Finalize(const NXStopwatch& gameTime)
			{
				RenderTargets[4].Set();
				RenderTargets[4].Clear(0, 0, 0, 0);
				combineShader.SetVSConstants();
				combineShader.SetPSResources();
				combineShader.Apply();
				renderQuad.RenderWithCustomEffect();
				HandleOutside(gameTime);

				NXGPU::SetToBackBuffer();
				NXGPU::DisableZBuffer();
			} 

After setting to render to my fourth target (putting final image in separate buffer for post process purposes; I'd like to the skybox to affected by motion blur as well), I render my quad with my combine shader, and I render outside objects (my skybox). As a result, I only see my skybox.  I've tried setting a blend state and rendering, and only saw the slightly transparent lit face of the cube but the skybox was still rendered correctly.  I've updated the dropbox.

Edited by KoldGames

Share this post


Link to post
Share on other sites

RenderTargets[4].Clear(0, 0, 0, 0);

^^ You're erasing the contents of the render-target before you draw the sky into it?

 

Also, is the depth-buffer bound, which was used earlier to render the rest of the scene?

Share this post


Link to post
Share on other sites

[font=courier new']RenderTargets[4].Clear(0, 0, 0, 0);[/font]
^^ You're erasing the contents of the render-target before you draw the sky into it?

Also, is the depth-buffer bound, which was used earlier to render the rest of the scene?

Hey! RenderTargets[4] doesn't have anything in it when I clear it. It's just a target that I render my final combined image to so I can pass it as a texture. After that, RenderTargets[4] is just sent to my post process manager which uses it as an input texture for the first effect, chains the rest of the effects together and renders the processed output to the screen. And I believe the depth buffer is bound.

Share this post


Link to post
Share on other sites

Oh, I thought you were rendering the sky into the same buffer that you rendered the lit scene into.

BTW, it's a bad habit to clear a target and then draw into every pixel of it (e.g. the sky also clears every pixel with the sky colour, so it's a waste of time to clear beforehand).

The flow should be:

                   Draw scene    -> [GBuffer/Depth]
[GBuffer/Depth] -> Draw Lighting -> [Accumulator]
                   Draw sky      -> [Accumulator/Depth]
[Accumulator]   -> Post Process  -> [Final] 

Share this post


Link to post
Share on other sites

Make sure you render the sky with the depth buffer from your scene enabled. But it should be done as Hodgman describes.

 

n!

Share this post


Link to post
Share on other sites

Hey guys! I got it working in Light Pre Pass (I didn't finish the renderer all the way but I finished it now).  Now I just have to get it working in Deferred Shading.

Share this post


Link to post
Share on other sites
Sign in to follow this