Archived

This topic is now archived and is closed to further replies.

Setting up KDE

This topic is 5877 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, After 3 days of struggling (and somehow screwing up my M$ XP boot record last night) I finally seem to have XP and linux installed properly. Now, what I want to do is, when linux boots, I want it to boot straight into the graphical KDE login screen, and then bring up the KDE desktop. I''ve really been struggling and I can''t seem to get this to work properly. Could someone please tell me which files exactly I need to edit to set this up? At the moment it seems to be loading xdm or something, and not the KDE window manager/desktop manager... and it brings up a window with the session option "default", but no others. I can get into KDE, using startx, with a .xinitsrc file, but It doesn''t bring up a login screen if I do it this way, and I want to do this from startup, but I don''t know how to set it up... Thanks in advance $£¥ We scratch our eternal itch A twentieth century bitch We are grateful for Our Iron Lung

Share this post


Link to post
Share on other sites
The file /etc/inittab changes the graphic login. If it understood it right do you have the graphic login so the rest should be done in KDE. You can enter your username and password and click go to start KDE but you can also makes thing easier.
I am using GNOME right now but it should be something like settings->system->loginmanager in the menus.The program is pretty easy to use and lets you skip password or enable automatic login for a user.

Share this post


Link to post
Share on other sites
Ok, assuming your setup is like mine this is what you do:
  • You'll need to be super user to do some of this.
  • Open a terminal and go to /etc/X11/xinit
  • Type "rm xinitrc"
  • Type "ln -s /opt/kde/bin/kdm xinitrc"
  • Now (this is what Obelix was talking about) open /etc/inittab
  • See the line that says "id:something:initdefault:"
  • Change that something to either 4 or 5 (depends on the distro, probably 5 for you)
  • DON'T CHANGE IT TO 0 OR 6, or your system will reboot or shutdown as its default boot behavior
    Good luck .

    [Resist Windows XP's Invasive Production Activation Technology!]

    Edited by - Null and Void on November 2, 2001 9:09:24 PM

    Share this post


    Link to post
    Share on other sites
    Hi, I''ve tried that, but it seems I was a little misunderstood.

    Linux now boots into a graphical login, which is what I want, but when I login, it runs TWM, and not the Kde window manager. What I want to know is how to load kwm after login, because I''m not getting the KDE start bar, etc. loaded.

    Thanks

    $£¥

    We scratch our eternal itch
    A twentieth century bitch
    We are grateful for
    Our Iron Lung

    Share this post


    Link to post
    Share on other sites
    On my system it goes like this, at some point the file
    /etc/X11/xinit/Xclients
    gets called, this file reads
    /etc/sysconfig/desktop
    to get the default desktop to load.

    /etc/sysconfig/desktop only contain one line:
    KDE
    so if your system works like this change the value in /etc/sysconfig/destop to KDE and see if it works, if it doesn''t have a look at the /etc/X11/xinit/Xclients file to work out what possible values can be put into the /etc/sysconfig/desktop file because it may be something like KDE2 instead.

    Hope thats what you want

    X2K

    Share this post


    Link to post
    Share on other sites
    Since I don''t know what kind of init you are using, here comes a suggestion that works on BSD systems (most Linux systems use sysV init though (this solution is actually a bit dated, but it still works))

    simply add something like:

    /usr/X11R6/bin/kdm

    to /etc/rc.local

    (once again, this is a dated BSD solution and will probably not work )

    /Mikael Jacobson

    Share this post


    Link to post
    Share on other sites