Sign in to follow this  
davididev

Still fairly new to 3D design...problem with my doom-style editor

Recommended Posts

davididev    103

I've been using Unity for about 8 months or so (I don't have a good sense of time), and I haven't really had much like trying to make levels out of objects made entirely in Blender...I mean I do fine with objecst like painting, shelves, doors, etc, but as for walls and ceilings, I haven't had much luck.

So I made another project in Unity to make those parts.  I modelled it after Pie in the sky's GCS 3.0, not Doom, but the basic idea is much like Doom- using nothing but Planes for walls, floors, and ceilings.  It doens't make real materials (you'd have to remake them in Unity anyway, so why bother?)

I've got everything working except for the normals.  The walls are supposed to be two-sided, the floors only to be seen from above, and the ceilings to be seen from below...

The ceilings are acting like floors.  The walls aren't working either, but I figure if I can find out what I'm doing wrong with the ceiling, I'll be able to fix the wall.

 

Can someone take a quick look at the .obj and tell me where I've gone wrong?

I'd appreciate it.

.obj: https://drive.google.com/file/d/0BwFIWa8-uYIhdGktRUNKVWJzNFE/edit?usp=sharing

.mtl: https://drive.google.com/file/d/0BwFIWa8-uYIhUmotMEJwaGVyZWs/edit?usp=sharing

 

Doubt you need the .mtl, but I thought I should include it just in case.

Share this post


Link to post
Share on other sites
Burnt_Fyr    1665

Generally this is an vertex winding issue. You need to reorder the vertices of the triangles that are facing the wrong way. Since you mention blender, I think a simple method would be to import the obj file in blender, hit tab to go to edit mode, select the faces (alt tab switches from vertex, to edge, to face select mode) that are backwards, and click normals->flip direction on the left hand tool bar. Then export the edited mesh and reload in unity. As for the walls, to be 2 sided they will need triangles facing both directions. if you hit n in the main window another tool bar will pop up on the right, scroll down to mesh display, and click the face button under "normals:" ( not the faces checkbox under "overlays:") This will show you what direction the faces face based on their current winding. you should see a normal pointing in both directions of the walls, and down for the ceiling and up for the floors. If this doesn't fix it, then blender and unity are using opposite handedness, and reversing the direction of all normals will fix it.

Share this post


Link to post
Share on other sites
Burnt_Fyr    1665

First sentence answered my question (at least with the ceilings)

 

Thanks so much.  It worked.  ^^

It's always a guess as to how detailed an answer to give, glad i could help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this