Sign in to follow this  

msaa

This topic is 1269 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, i try add msaa to my project, but eglChooseConfig(g_display, configAttributes, &config, 1, &countConfig) returning countConfig = 0, how i can check support msaa ?

code:

EGLint configAttributes[] =
    {
        EGL_RED_SIZE,       8,
        EGL_GREEN_SIZE,     8,
        EGL_BLUE_SIZE,      8,
        EGL_ALPHA_SIZE,     8,
        EGL_DEPTH_SIZE,     24,
        EGL_STENCIL_SIZE,   8,
EGL_SAMPLE_BUFFERS, 1,
EGL_SAMPLES,        4,
        EGL_NONE
    };
 
if(EGL_FALSE == eglChooseConfig(g_display, configAttributes, &config, 1, &countConfig)) || countConfig != 1)
{
MB(L"eglChooseConfig - Failed");
return 0;
}

 

Share this post


Link to post
Share on other sites

I'm not a pro on opengl es but the I guess standard method would be drawing to a multisample framebuffer object you have created with glCreateFramebuffers () and when you have finished rendering resolve the multisample framebuffer to you backbuffer with glBlitFramebuffer ().

Hope that helps.

Share this post


Link to post
Share on other sites
Try setting EGL_SAMPLES to 1 and you should be returned a list of configs that support 1 or more samples. If there are none then your graphics driver is saying it doesn't support MSAA configs.

Share this post


Link to post
Share on other sites

This topic is 1269 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this