Jump to content
  • Advertisement
Sign in to follow this  
Endemoniada

Strange VS2012 Debug Problem

This topic is 1495 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi guys,

 

I don't think this has ever happened before and it's really weird.

 

struct Joint{

char name[32];

int count;

};

 

In my program:

 

Joint* joint=getJoint(...); // i get a good Joint pointer back

if(joint){...

 

Normally when I debug and hover over a struct variable it has a little popup with the member variables. If I hover the variable 'joint' above I now get this:

 

cb=1970235507

ver=1919247468

offszCwd=3435973868

offszCommand=3435973836

ichOutfile=3435973836

offszLibs=3435973836

 

...and when I put it in the watch window it says:

 

joint->count     : class "Joint" has no member 'count'

 

And it doesn't just happen with Joint. I made sure I'm running the debug build, What's going on ?

 

Thanks.

 

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!