Sign in to follow this  
HassaanAtif

Unity 3d help!

Recommended Posts

Lights in Unity don't have a 3D model, they have 2D gizmos. Make sure you have gizmos turned on and that your light's position is not a weird number.

 

If you still can't find it, double click on the light in the hierarchy and you'll see the object in the editor's 3D view.

Edited by DiegoSLTS

Share this post


Link to post
Share on other sites

Make sure that lighting is turned on in the scene when editing, the lightbulb icon over the scene is a toggle for that. Many times when editing worlds it is nice to see everything regardless of the in-game light. It is easy to see it in action: if you are missing lights and hit the toggle the world will go dark.  Typically you want at least one light, usually a general directional light that provides ambient light to everything.

Share this post


Link to post
Share on other sites

What the other two said....

 

Also make sure your light is not just somewhere in the back, where its lighting volume does not intersect with any scene geometry. Lights created from the menu are often placed in the far back for some reason. Check the position settings and the rotation.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this