Archived

This topic is now archived and is closed to further replies.

loko

visualC6 and directplay8

Recommended Posts

loko    122
Hi. I have a problem using directplay. I get errors on the dplay8.h file which comes with the SDK. Meaning, I have a program without any errors or warnning, and when I add the line #include I get 18 errors on the dplay8.h file. I use C, and not C++; I also added to the project all the dp*.lib files. The error I get is that the '')'' char is expected before the *. This error is at a definition of a register lobby line. All 18 erros are at three lines which each one define the registerlobby method. Did any one encountered such a problem? Please help!

Share this post


Link to post
Share on other sites
Pactuul    122
sounds like a very common syntax error.


one thing to check for is to see if your project directories lists the sdk directory in it..Check under tools and options I believe. and make sure vc++ has got the sdk include and soure directories listed

Share this post


Link to post
Share on other sites
JasonA    152
I think Pactuul''s right... loko make sure you list the dxsdk directory **BEFORE** VC++6''s directory already listed.
Tell us how it works out for you..

Jason Arora
jason@pubism.com
http://www.pubism.com

Share this post


Link to post
Share on other sites
jwalker    122
i have heard of this.
the mssdk 8 has problems with C language.
There are some code not conforming to C in the header
of some of the libraries.

search MSDN, there is a macro for you to
define before including directplay8 ..

i cant remember what it is.



{ Stating the obvious never helped any situation !! }

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
I don''t have a problem with the directories, I use other directX at the same program.
Maybe the macro that jwalker talked about is what I need. Do you know about a spesific macro to directplay or do you talk about the INITGUID macro?

Share this post


Link to post
Share on other sites