Jump to content
  • Advertisement
Sign in to follow this  
danong

ENet Dynamic Memory data send out fine, but receive corrupted data

This topic is 1411 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Dear All,

 

I am using ENet library for my multiplayer game, which I am trying to create dynamic memory allocated packet.

 

I tested it successfully but somehow at a certain point of time, the packet is sent over successfully but when received the data is messed up, and totally corrupted. 

 

May I know what's the cause of this during the transfer of data?

 

And is there any compensation method? 

 

Currently I am trying to check the entire game states several frames but it is not my intention to do so since it will slow down the performance by checking the entire world once every few frames to keep client & server in sync.

 

Thank you for reading and answering my question.

 

 

Best regards,

Dan.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!