Jump to content
  • Advertisement
Sign in to follow this  
tragic

Issues with linking Fmod Studio low level library into project

This topic is 1343 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So visual studio is kicking my ***, Im attempting to integrate fmod into on of the DLL's for my game/engine but im having the issue with not being able to open the fmod.hpp header file or any of the header files.

error C1083: Cannot open include file: 'fmod.hpp': No such file or directory

I have the following settings in VS 2012

 

C/C++ -> Additional Include Directories -> C:\Program Files (x86)\FMOD SoundSystem\FMOD Studio API Windows\api\lowlevel\inc

Linker -> General -> Additional Library Directories -> C:\Program Files (x86)\FMOD SoundSystem\FMOD Studio API Windows\api\lowlevel\lib

Linker -> Input -> Additional Dependencies ->  fmod_vc.lib

 

I am compiling for Win32 with Debug. All of the DLL's but the one which is including fmod compile, the executable also compiles.

 

If any additional details are needed please ask.

 

Thanks,

Tragic

Share this post


Link to post
Share on other sites
Advertisement

Is fmod.hpp inside C:\Program Files (x86)\FMOD SoundSystem\FMOD Studio API Windows\api\lowlevel\inc ?

Share this post


Link to post
Share on other sites
I've tried both <> and "".
That path does contain fmod.hpp as well as fmod.h(this is the C interface where as the former is the C++ interface).

Share this post


Link to post
Share on other sites

In Visual Studio, in the cpp file that contains the line in question, right-click on the line #include <fmod.hpp>, and select Open Document "fmod.hpp" If you can't open it, then your project configuration properties VC++ Directories->Include Directories setting is incorrect. Fix that.

 

If that doesn't provide the solution, try changing that line as follows and compile:
 

#include "C:\Program Files (x86)\FMOD SoundSystem\FMOD Studio API Windows\api\lowlevel\inc\fmod.hpp"


You can also try copying fmod.hpp directly to your project directory and #include "fmod.hpp"

Otherwise post the first several lines of the cpp file that contains and shows the line:
 

#include <fmod.hpp>
Edited by Buckeye

Share this post


Link to post
Share on other sites

Buckeye's solution fixed the issue.  But I still find it very odd that Open Document <fmod.hpp> did in fact work but at compile time the file couldn't be opened.

 

The solution that worked below.

 #include "C:\Program Files (x86)\FMOD SoundSystem\FMOD Studio API Windows\api\lowlevel\inc\fmod.hpp" fixed the issue but it was weird since i could 

Thanks to everyone who replied.

Edited by tragic

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!