Jump to content
  • Advertisement
Sign in to follow this  
Misantes

OpenGL OpenGL/GLSL version handling

This topic is 1331 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So, some general advice is needed here.

 

I recently got a laptop that only supports glsl 1.3 and opengl 3.0 (it's a chromebook 14, with chromeOS erased and Ubuntu 14.10 installed over it).

I'm realizing that with my current project, I've written the shaders with 330 support. I'd like it to support glsl 1.3 as well. I think the only things in my shaders that aren't compatible are the "layout" portions of things (they're rather simple lighting shaders). I've made a build that adds glBindAttribLocation and glBindFragDataLocation on object creation, and changed the shaders to account for that. It runs, albeit rather jittery, though I haven't profiled it to find out why yet.

 

If I don't want to maintain two builds, what's the best way to handle this? My initial reaction is to have a low/high setting, and depending on which, on item creation have two separate rendering methods. However, I was curious how everyone else handled this. Is there any performance benefit to using the layout functions, or is this purely for convenience? If it's just convenience, I'm happy to simply use the deprecated functions and have it support lower end hardware.

 

Anyhow, I'm curious to know everyone else's approach to compatibility, as this is rather a new realm for me.

 

Cheers, and thanks!

Edited by Misantes

Share this post


Link to post
Share on other sites
Advertisement

What the GL driver does with the locations is the same as if you called glBindAttribLocation and glBindFragDataLocation, except the location comes from your shader and not through an API call. The only difference is that the layout qualifier is a lot more convenient as you don't have to recompile your code.

 

Those two API functions, by the way, aren't deprecated. They're just an alternative way of doing things.

Share this post


Link to post
Share on other sites


I recently got a laptop that only supports glsl 1.3 and opengl 3.0 (it's a chromebook 14, with chromeOS erased and Ubuntu 14.10 installed over it).
Which one exactly? 

 

If its the one with the 2955U Celeron,  It might have an Intel HD 4xxx card or similar which should run OpenGL 3.3 fine. I'm not sure what kind of Mesa drivers Ubuntu ships tho.

 

If its one with a Tegra chip, then it might go up to OpenGL 4.4 if its recent (not sure how the state of the linux drivers are for Tegra either).

 

OpenGL 3.0 only seems kinda weird, most OpenGL 3 class hardware go up to 3.1 with updated drivers, 3.2 if they support geometry shaders, or 3.3 if they support geometry shaders and the vendor feels like supporting it.

Share this post


Link to post
Share on other sites

 


I recently got a laptop that only supports glsl 1.3 and opengl 3.0 (it's a chromebook 14, with chromeOS erased and Ubuntu 14.10 installed over it).
Which one exactly? 

 

If its the one with the 2955U Celeron,  It might have an Intel HD 4xxx card or similar which should run OpenGL 3.3 fine. I'm not sure what kind of Mesa drivers Ubuntu ships tho.

 

If its one with a Tegra chip, then it might go up to OpenGL 4.4 if its recent (not sure how the state of the linux drivers are for Tegra either).

 

OpenGL 3.0 only seems kinda weird, most OpenGL 3 class hardware go up to 3.1 with updated drivers, 3.2 if they support geometry shaders, or 3.3 if they support geometry shaders and the vendor feels like supporting it.

 

You're might be correct (though it still refuses to show anything tongue.png), it may have 3.3 support for opengl. But, glsl still shows 1.3 (i think). What's the difference between core and version support?

Hm. It does have a 2955U celeron, I'm going to admit, I'm a little uncertain on the video card (also, a little uncertain on verifying the card info. I've never used an on-board graphics card as this is my first laptop). The system reports just "Intel Haswell Mobile" and lspci | grep VGA just reports 

VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

similarly, sudo lshw -C video reports only:

description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0b
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:59 memory:e0000000-e03fffff memory:d0000000-dfffffff iopor

I'm on the 3.16 kernel, with 14.10. I've upgraded to Mesa 10, but it still reports only 3.0 (unless I'm reading things wrong).

grep opengl reports:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.4.0-devel (git-8c7ac37 2014-10-24 trusty-oibaf-ppa)
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.4.0-devel (git-8c7ac37 2014-10-24 trusty-oibaf-ppa)
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.4.0-devel (git-8c7ac37 2014-10-24 trusty-oibaf-ppa)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:

How do the core and version profiles differ? If I leave in the "core" part of my shaders, it refuses to render, though, if I remove it, things work fine.

I would absolutely love to get this running modern opengl. If you have any advice on where I may be going wrong configuring things, I'd appreciate the input.

 

@ Xycaleth

That's wonderful to know, especially if I end up not getting the 3.3 support running.

Edited by Misantes

Share this post


Link to post
Share on other sites

What's the difference between core and version support?
You should read up on OpenGL profiles then. It seems your card supports core 3.3, and GLSL 3.30.

 

Mesa drivers doesn't implements ARB_compatibility extension, thus, you only got 'core' profiles, ie, no deprecated functions.

 

I'm not sure what that second "version" is, maybe its just Mesa's software OpenGL implementation, or just the version of a dummy context created to query OpenGL data, no idea. But you should be looking at the first one, the 'core' version.

 

Just try to create an OpenGL 3.3 core/forward compatible context and use #version 330 in your GLSL files. If you can create it and run it, then your rendering issues must be somewhere else (hello different driver implementations!).

 

Are you using deprecated functions? Did you coded initially on a nVidia card? nVidia drivers tends to be more lenient, whereas AMD and possibly Intel drivers might strive more to follow the OGL spec to the letter (first time I ran my shaders on an AMD card, it practically spit on my face :D ).

 

Then again, sometimes its nothing to do with the spec, driver just bugs out at specific circumstances.

Share this post


Link to post
Share on other sites

They're fairly basic shaders, using #version 330 core, no ARB functions, though they were initially developed on an nvidia driver.

 

Though, it appears you're right, and it looks like I just have a driver/library error somewhere. as the error I'm now getting is:

X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 34 ()
Serial number of failed request: 75
Current serial number in output stream: 74

downgrading to version 130 gets rid of it, with the appropriate changes to the shader, but I think I was mistaken initially, in reading the second output of grep opengl, and the fact that it ran as 130. But, after digging a little, that error is usually associated with driver and library issues. I can't quite parse it myself, but I'll keep looking into it and see where I've gone wrong in my upgrade.

 

If I had to guess, it's because I initially used the intel graphics driver tool to update my graphics driver, but it's not supported on 14.10 yet, so there are probably lingering files in there somewhere. I reinstalled mesa, as it was still on the trusty build, but that didn't seem to fix it. If you have any insight, I'm all ears. 

 

edit*

Though, I should note that I was getting that error on 14.04 as well, prior to upgrading anything, so I'm a little skeptical that the issue is there.

In hindsight, upgrading to 14.10 may have been a bit premature (I had read that the intel drivers got a bit of love, support-wise, I tend to wait a bit for upgrades). So, I may end up just downgrading/reinstalling the lts version for the time being and trying again. I loathe driver issues tongue.png

Edited by Misantes

Share this post


Link to post
Share on other sites

It's almost like TheChubu said:

You only get GLSL 3.30 when you create a core-context with version 3.3. The other version-info shown in your output (I guess it's from glxinfo) is for old non-core contexts.

This irritated the hell out of me when I first encountered this behaviour :-)

So everything regarding your drivers seems to be correct!

 

Are you using GL_KHR_debug or GL_ARB_debug_output yet?

I can really recommend using them as they might give you more information about the error you are still encountering.

 

Regards

Markus

Share this post


Link to post
Share on other sites
Anyhow, I'm curious to know everyone else's approach to compatibility, as this is rather a new realm for me.

I use a 2 step mechanism, a coarse one bases on dynamic library selection, and a fine one based on late binding. This works because of a layered solution of the graphics sub-system.

 

First of, somewhere in the starting process of the application, a OpenGL context is created with the highest supported version. If this fails then a context with the next lower version is tried until the lowest supported version. This can be done in a comfortable way on Mac OS, because it gives one the highest available version when asked for a 3.2 core profile anyway. On Windows, the process is less comfortable. However, if a context was generated, the belonging dynamic library is loaded. If this fails, then again the next lower version for context creation is tried. In the end I hope to have a library successfully loaded, or else the application is not runnable, of course. 

 

Such a library brings in the lowest layer of the graphics sub-system w.r.t. the own implementation. It is able to process graphics jobs that are generated within the middle layer of the graphics sub-system. However, when a library was loaded successfully it has a defined minimum of features. Additional features or better implementations are then recognized by the set-up routine of the graphics sub-system layer loaded with the library. This is based on investigating the minor version number and the extensions. The layer then does symbol binding by its own.

 

Regarding shader scripts: Some scripts are assembled at the runtime, and this considers to use the mechanisms available from the loaded library. Pre-made scripts need to be available for each loadable library, of course, and hence are simply selected.

 

 

EDIT: BTW: The above mechanism is not only used for version compatibility but is abstract enough to also select between OpenGL and D3D.

Edited by haegarr

Share this post


Link to post
Share on other sites

Ick,

So, everything seems to be sorted out driver-wise. However, my current program uses opengl within an sfml context window. According to the sfml forums:

sfml-graphics will not allow you to use GLSL 1.30 or higher on systems that are only able to provide GLSL 1.30 or higher exclusively in core contexts.

I read up a bit on opengl profiles, and if I'm reading the output right, my driver only supports glsl 130 and opengl 3.0 without a explicitly creating core contexts. So, I believe I may be SOL with running this project on this system within sfml (my non-sfml OpenGL programs handle it just fine, after some testing).

 

If anyone's dealt with this before, I'm open to advice, but it seems a bit of a fringe problem. I'll likely try to implement haegarr's advice and create a  version 130 shader if it reports that as the highest available.

 

Otherwise, thank you for the input everyone. 

Edited by Misantes

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
  • Advertisement
  • Popular Tags

  • Similar Content

    • By plz717
      Hello, everyone! I hope my problem isn't too 'beginnerish'. I'm doing research on motion synthesis now, trying to implement the Deep Mimic paper (DeepMimic) by BINPENG XUE, in this paper, I need to first retarget character A's motion to another character B to make the reference motion clips for character B, since we don't have character B‘s reference motion. The most important thing is that in the paper, the author copied character A's joint's rotation with respective to joint's local coordinate system (not the parent) to character B. In my personal understanding, the joint's rotation with respective to joint's local coordinate system is something like that in the attached photo, where for the Elbow joint, i need to get the Elbow's rotation in the elbow's local coordinate system (i'm very grateful for you to share your ideas if i have misunderstanding about it 🙂)
      I have searched many materials on the internet about how to extract the local joint's information from FBX, the most relative one i found is the pivot rotation( and geometric transformation, object offset transformation). I'm a beginner in computer graphics, and i'm confused about whether the pivot rotation( or geometric transformation, object offset transformation) is exactly the joint's local rotation i'm seeking? I hope someone that have any ideas can help me, I'd be very grateful for any pointers in the right direction. Thanks in advance! 

    • By nOoNEE
      hello guys , i have some questions  what does glLinkProgram  and  glBindAttribLocation do?  i searched but there wasnt any good resource 
    • By owenjr
      Hi, I'm a Multimedia Engineering student. I am about to finish my dergree and I'm already thinking about what topic to cover in my final college project.
      I'm interested in the procedural animation with c++ and OpenGL of creatures, something like a spider for example. Can someone tell me what are the issues I should investigate to carry it out? I understand that it has some dependence on artificial intelligence but I do not know to what extent. Can someone help me to find information about it? Thank you very much.
       
      Examples: 
      - Procedural multi-legged walking animation
      - Procedural Locomotion of Multi-Legged Characters in Dynamic Environments
    • By Lewa
      So, i'm still on my quest to unterstanding the intricacies of HDR and implementing this into my engine. Currently i'm at the step to implementing tonemapping. I stumbled upon this blogposts:
      http://filmicworlds.com/blog/filmic-tonemapping-operators/
      http://frictionalgames.blogspot.com/2012/09/tech-feature-hdr-lightning.html
      and tried to implement some of those mentioned tonemapping methods into my postprocessing shader.
      The issue is that none of them creates the same results as shown in the blogpost which definitely has to do with the initial range in which the values are stored in the HDR buffer. For simplicity sake i store the values between 0 and 1 in the HDR buffer (ambient light is 0.3, directional light is 0.7)
      This is the tonemapping code:
      vec3 Uncharted2Tonemap(vec3 x) { float A = 0.15; float B = 0.50; float C = 0.10; float D = 0.20; float E = 0.02; float F = 0.30; return ((x*(A*x+C*B)+D*E)/(x*(A*x+B)+D*F))-E/F; } This is without the uncharted tonemapping:
      This is with the uncharted tonemapping:
      Which makes the image a lot darker.
      The shader code looks like this:
      void main() { vec3 color = texture2D(texture_diffuse, vTexcoord).rgb; color = Uncharted2Tonemap(color); //gamma correction (use only if not done in tonemapping code) color = gammaCorrection(color); outputF = vec4(color,1.0f); } Now, from my understanding is that tonemapping should bring the range down from HDR to 0-1.
      But the output of the tonemapping function heavily depends on the initial range of the values in the HDR buffer. (You can't expect to set the sun intensity the first time to 10 and the second time to 1000 and excpect the same result if you feed that into the tonemapper.) So i suppose that this also depends on the exposure which i have to implement?
      To check this i plotted the tonemapping curve:
      You can see that the curve goes only up to around to a value of 0.21 (while being fed a value of 1) and then basically flattens out. (which would explain why the image got darker.)
       
      My guestion is: In what range should the values in the HDR buffer be which then get tonemapped? Do i have to bring them down to a range of 0-1 by multiplying with the exposure?
      For example, if i increase the values of the light by 10 (directional light would be 7 and ambient light 3) then i would need to divide HDR values by 10 in order to get a value range of 0-1 which then could be fed into the tonemapping curve. Is that correct?
    • By nOoNEE
      i am reading this book : link
      in the OpenGL Rendering Pipeline section there is a picture like this: link
      but the question is this i dont really understand why it is necessary to turn pixel data in to fragment and then fragment into pixel could please give me a source or a clear Explanation that why it is necessary ? thank you so mu
       
       
    • By Inbar_xz
      I'm using the OPENGL with eclipse+JOGL.
      My goal is to create movement of the camera and the player.
      I create main class, which create some box in 3D and hold 
      an object of PlayerAxis.
      I create PlayerAxis class which hold the axis of the player.
      If we want to move the camera, then in the main class I call to 
      the func "cameraMove"(from PlayerAxis) and it update the player axis.
      That's work good.
      The problem start if I move the camera on 2 axis, 
      for example if I move with the camera right(that's on the y axis)
      and then down(on the x axis) -
      in some point the move front is not to the front anymore..
      In order to move to the front, I do
      player.playerMoving(0, 0, 1);
      And I learn that in order to keep the front move, 
      I need to convert (0, 0, 1) to the player axis, and then add this.
      I think I dont do the convert right.. 
      I will be glad for help!

      Here is part of my PlayerAxis class:
       
      //player coordinate float x[] = new float[3]; float y[] = new float[3]; float z[] = new float[3]; public PlayerAxis(float move_step, float angle_move) { x[0] = 1; y[1] = 1; z[2] = -1; step = move_step; angle = angle_move; setTransMatrix(); } public void cameraMoving(float angle_step, String axis) { float[] new_x = x; float[] new_y = y; float[] new_z = z; float alfa = angle_step * angle; switch(axis) { case "x": new_z = addVectors(multScalar(z, COS(alfa)), multScalar(y, SIN(alfa))); new_y = subVectors(multScalar(y, COS(alfa)), multScalar(z, SIN(alfa))); break; case "y": new_x = addVectors(multScalar(x, COS(alfa)), multScalar(z, SIN(alfa))); new_z = subVectors(multScalar(z, COS(alfa)), multScalar(x, SIN(alfa))); break; case "z": new_x = addVectors(multScalar(x, COS(alfa)), multScalar(y, SIN(alfa))); new_y = subVectors(multScalar(y, COS(alfa)), multScalar(x, SIN(alfa))); } x = new_x; y = new_y; z = new_z; normalization(); } public void playerMoving(float x_move, float y_move, float z_move) { float[] move = new float[3]; move[0] = x_move; move[1] = y_move; move[2] = z_move; setTransMatrix(); float[] trans_move = transVector(move); position[0] = position[0] + step*trans_move[0]; position[1] = position[1] + step*trans_move[1]; position[2] = position[2] + step*trans_move[2]; } public void setTransMatrix() { for (int i = 0; i < 3; i++) { coordiTrans[0][i] = x[i]; coordiTrans[1][i] = y[i]; coordiTrans[2][i] = z[i]; } } public float[] transVector(float[] v) { return multiplyMatrixInVector(coordiTrans, v); }  
      and in the main class i have this:
       
      public void keyPressed(KeyEvent e) { if (e.getKeyCode()== KeyEvent.VK_ESCAPE) { System.exit(0); //player move } else if (e.getKeyCode()== KeyEvent.VK_W) { //front //moveAmount[2] += -0.1f; player.playerMoving(0, 0, 1); } else if (e.getKeyCode()== KeyEvent.VK_S) { //back //moveAmount[2] += 0.1f; player.playerMoving(0, 0, -1); } else if (e.getKeyCode()== KeyEvent.VK_A) { //left //moveAmount[0] += -0.1f; player.playerMoving(-1, 0, 0); } else if (e.getKeyCode()== KeyEvent.VK_D) { //right //moveAmount[0] += 0.1f; player.playerMoving(1, 0, 0); } else if (e.getKeyCode()== KeyEvent.VK_E) { //moveAmount[0] += 0.1f; player.playerMoving(0, 1, 0); } else if (e.getKeyCode()== KeyEvent.VK_Q) { //moveAmount[0] += 0.1f; player.playerMoving(0, -1, 0); //camera move } else if (e.getKeyCode()== KeyEvent.VK_I) { //up player.cameraMoving(1, "x"); } else if (e.getKeyCode()== KeyEvent.VK_K) { //down player.cameraMoving(-1, "x"); } else if (e.getKeyCode()== KeyEvent.VK_L) { //right player.cameraMoving(-1, "y"); } else if (e.getKeyCode()== KeyEvent.VK_J) { //left player.cameraMoving(1, "y"); } else if (e.getKeyCode()== KeyEvent.VK_O) { //right round player.cameraMoving(-1, "z"); } else if (e.getKeyCode()== KeyEvent.VK_U) { //left round player.cameraMoving(1, "z"); } }  
      finallt found it.... i confused with the transformation matrix row and col. thanks anyway!
    • By Lewa
      So, i'm currently trying to implement an SSAO shader from THIS tutorial and i'm running into a few issues here.
      Now, this SSAO method requires view space positions and normals. I'm storing the normals in my deferred renderer in world-space so i had to do a conversion and reconstruct the position from the depth buffer.
      And something there goes horribly wrong (which has probably to do with worldspace to viewspace transformations).
      (here is the full shader source code if someone wants to take a look at it)
      Now, i suspect that the normals are the culprit.
      vec3 normal = ((uNormalViewMatrix*vec4(normalize(texture2D(sNormals, vTexcoord).rgb),1.0)).xyz); "sNormals" is a 2D texture which stores the normals in world space in a RGB FP16 buffer.
      Now i can't use the camera viewspace matrix to transform the normals into viewspace as the cameras position isn't set at (0,0,0), thus skewing the result.
      So what i did is to create a new viewmatrix specifically for this normal without the position at vec3(0,0,0);
      //"camera" is the camera which was used for rendering the normal buffer renderer.setUniform4m(ressources->shaderSSAO->getUniform("uNormalViewMatrix"), glmExt::createViewMatrix(glm::vec3(0,0,0),camera.getForward(),camera.getUp())//parameters are (position,forwardVector,upVector) ); Though i have the feeling this is the wrong approach. Is this right or is there a better/correct way of transforming a world space normal into viewspace?
    • By HawkDeath
      Hi,
      I'm trying mix two textures using own shader system, but I have a problem (I think) with uniforms.
      Code: https://github.com/HawkDeath/shader/tree/test
      To debug I use RenderDocs, but I did not receive good results. In the first attachment is my result, in the second attachment is what should be.
      PS. I base on this tutorial https://learnopengl.com/Getting-started/Textures.


    • By norman784
      I'm having issues loading textures, as I'm clueless on how to handle / load images maybe I missing something, but the past few days I just google a lot to try to find a solution. Well theres two issues I think, one I'm using Kotlin Native (EAP) and OpenGL wrapper / STB image, so I'm not quite sure wheres the issue, if someone with more experience could give me some hints on how to solve this issue?
      The code is here, if I'm not mistaken the workflow is pretty straight forward, stbi_load returns the pixels of the image (as char array or byte array) and you need to pass those pixels directly to glTexImage2D, so a I'm missing something here it seems.
      Regards
    • By Hashbrown
      I've noticed in most post processing tutorials several shaders are used one after another: one for bloom, another for contrast, and so on. For example: 
      postprocessing.quad.bind() // Effect 1 effect1.shader.bind(); postprocessing.texture.bind(); postprocessing.quad.draw(); postprocessing.texture.unbind(); effect1.shader.unbind(); // Effect 2 effect2.shader.bind(); // ...and so on postprocessing.quad.unbind() Is this good practice, how many shaders can I bind and unbind before I hit performance issues? I'm afraid I don't know what the good practices are in open/webGL regarding binding and unbinding resources. 
      I'm guessing binding many shaders at post processing is okay since the scene has already been updated and I'm just working on a quad and texture at that moment. Or is it more optimal to put shader code in chunks and bind less frequently? I'd love to use several shaders at post though. 
      Another example of what I'm doing at the moment:
      1) Loop through GameObjects, bind its phong shader (send color, shadow, spec, normal samplers), unbind all.
      2) At post: bind post processor quad, and loop/bind through different shader effects, and so on ...
      Thanks all! 
  • Advertisement
  • Popular Now

  • Forum Statistics

    • Total Topics
      631395
    • Total Posts
      2999780
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!