Archived

This topic is now archived and is closed to further replies.

Kaezin

More link errors...

Recommended Posts

Kaezin    158
Keep...getting...stupid...errors... Compiling resources... Compiling... class_func.cpp functions.cpp game.cpp player.cpp graphics.cpp Linking... graphics.obj : error LNK2001: unresolved external symbol "public: __thiscall CDisplay::~CDisplay(void)" (??1CDisplay@@QAE@XZ) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CSurface::SetColorKey(unsigned long)" (?SetColorKey@CSurface@@QAEJK@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::CreateSurfaceFromText(class CSurface * *,struct HFONT__ *,char *,unsigned long,unsigned long)" (?CreateSurfaceFromText@CDisplay@@QAEJPAPAVCSurface@@PAUHFONT_ _@@PADKK@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::CreateSurfaceFromBitmap(class CSurface * *,char *,unsigned long,unsigned long)" (?CreateSurfaceFromBitmap@CDisplay@@QAEJPAPAVCSurface@@PADKK@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::SetPalette(struct IDirectDrawPalette *)" (?SetPalette@CDisplay@@QAEJPAUIDirectDrawPalette@@@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::CreatePaletteFromBitmap(struct IDirectDrawPalette * *,char const *)" (?CreatePaletteFromBitmap@CDisplay@@QAEJPAPAUIDirectDrawPalette@@PBD@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::CreateFullScreenDisplay(struct HWND__ *,unsigned long,unsigned long,unsigned long)" (?CreateFullScreenDisplay@CDisplay@@QAEJPAUHWND__@@KKK@Z) graphics.obj : error LNK2001: unresolved external symbol "public: __thiscall CDisplay::CDisplay(void)" (??0CDisplay@@QAE@XZ) graphics.obj : error LNK2001: unresolved external symbol "public: __thiscall CSurface::~CSurface(void)" (??1CSurface@@QAE@XZ) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::UpdateBounds(void)" (?UpdateBounds@CDisplay@@QAEJXZ) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay:resent(void)" (?Present@CDisplay@@QAEJXZ) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::Blt(unsigned long,unsigned long,class CSurface *,struct tagRECT *)" (?Blt@CDisplay@@QAEJKKPAVCSurface@@PAUtagRECT@@@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CDisplay::Clear(unsigned long)" (?Clear@CDisplay@@QAEJK@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CSurface::DrawBitmap(char *,unsigned long,unsigned long)" (?DrawBitmap@CSurface@@QAEJPADKK@Z) graphics.obj : error LNK2001: unresolved external symbol "public: long __thiscall CSurface::DrawTextA(struct HFONT__ *,char *,unsigned long,unsigned long,unsigned long,unsigned long)" (?DrawTextA@CSurface@@QAEJPAUHFONT__@@PADKKKK@Z) Arcantia___Win32_Debug/Arcantia.exe : fatal error LNK1120: 15 unresolved externals Error executing link.exe. 16 error(s), 0 warning(s) I know I included everything right, I have all the directories in my project settings, but this keeps popping up! Btw my lib directory is "C:\dx8\lib"... why?!? **Sobs**

Share this post


Link to post
Share on other sites
mickey    100
hey we have the same problem, you''re trying to include the libs in the i think tools-options-directories tab yeah you should do that but you should also include the libs in this:

projects-settings and under the link tab put the appropriate libs like d3d8.lib etc., coz the problem you''re having is not in compiling but in the linking phase hope this thing helped you out

Share this post


Link to post
Share on other sites