Archived

This topic is now archived and is closed to further replies.

Viscous-Flow

Any Ideas?

Recommended Posts

Hello, I have this triangle that is moved across the screen (using glTranslatef()) succesively each frame according to a deltaTime variable and an OpenGL window. Why would a program''s frames per second rate decrease by about 40fps to 70-80fps when one triangle is drawn in the center? When the triangle is not being displayed the frame rate increases by 40fps to 120fps. I doubt it is my fill rate since professional quality games have well over one triangle (just take a look at Half-Life) and they generally do some sort of intensive physics or collision detection whereas all mine is doing is *just* drawing one triangle in the center of the screen. On my computer Half-Life gets about 35-45fps consistently when playing online. I have noticed that if I turn off depth testing the fps increases by about 10-15fps, but the frame rate still drops noticeably by about 40fps, so noticeably in fact, that the image "twitches" when it is in the center due to the deltaTime variable getting larger since it takes more time (I guess) to draw the triangle in the center. The drop in fps doesn''t make the triangle look to pretty. If timing is disabled, the triangle noticeably slows down by at least half when it is in the center and increases as it gets away from the center. Well, do you got any ideas about how to combat this frustrating issue? System Specs: 733 MHz 256 MB of SDram Probably the source of the issue: ** TNT2 Vanta AGP **

Share this post


Link to post
Share on other sites
It may be useful to note that I ran those tests in 800x600 resolution.

If I run it at 640x480 the framerate increases by about 40fps to 160, but it still takes a 40-60fps hit when the triangle comes near the center of the screen.

Mind boggling, isn''t it?!?

Share this post


Link to post
Share on other sites
if the triangle is bigger in the middle of the screen (it should be if u use a perspective projection matrix) + the framerate decreases cause the triangle is bigger then the problem is the fillrate.
all cards suffer from fillrate limits IIRC a vanta has theoretical max 125milpixels a second fillrate. though if u turn on textures/depth testing/blending etc this value will decrease quite a bit

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
If you have texturing on, turn it off an see if that helps. If it did, decease the size of your texture: it''s too big.

Share this post


Link to post
Share on other sites