Jump to content
  • Advertisement
Sign in to follow this  
neeker

OpenGL Weird winding behavior porting to GLES

This topic is 1256 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

 

I'm working on porting a graphics application from OpenGL 2.1 to GLES 3.0.  I have a sky dome which renders fine on OSX, but will not render on Android unless I reverse the culling mode (i.e. switch to GL_FRONT).  However, if I do this the sky dome will no longer render on OSX.

 

Since my understanding is that both of these systems should have the same default culling behavior, I'm wondering if I missed something in initialization?  Or is there something else that can cause this behavior?

Share this post


Link to post
Share on other sites
Advertisement


Since my understanding is that both of these systems should have the same default culling behavior, I'm wondering if I missed something in initialization? 
Yes, set the winding order to whatever you need on all platforms, don't rely on the default settings being properly set. Specially on mobile you're bound to hit a rough spot in some device somewhere that doesn't does what it should do.

 

Also: https://www.opengl.org/wiki/Face_Culling

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!