Archived

This topic is now archived and is closed to further replies.

Problems running the tools/samples from DX8.1 SDK

This topic is 5881 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just installed the 8.1 SDK yesterday but for some reason, whenever I try to run a tool or sample that came with the SDK, it crashed. I have no idea why this would happen since other things that use DX still seam to be working. Any insight into this problem would be greatly appreciated. Thanks

Share this post


Link to post
Share on other sites
I installed it and it works -- except that it broke my code that was using 32 bit index buffers -- works fine now that i changed it to 16 bits. Are you sure you have the latest driver for your card? try running the diagnostic tool from the directx control panel applet.

Share this post


Link to post
Share on other sites
I have the latest drivers for my voodoo 3 but I''m running XP. I''ve done all the diagnostics and everything seems fine. I also doubt that''s the problem since I can run other things that require DX.

Share this post


Link to post
Share on other sites
Try running DXDIAG (go to the Run... option from the Start menu and type DXDIAG) - after a few seconds delay (when it checks the WHQL status of your drivers) it''ll pop up and should indicate any problems it finds.

If you have XP, then you''ve already been using DX8.1 since that ships as standard. I assume this is a final release of XP rather than a beta or a "hacked" beta.

--
Simon O''''Connor
Creative Asylum Ltd
www.creative-asylum.com

Share this post


Link to post
Share on other sites