• Advertisement

Archived

This topic is now archived and is closed to further replies.

question

This topic is 5943 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi..i was folowing the dgraphic tutorial in this site http://www.gamedev.net/reference/articles/article1434.asp in my app the drawing will onli appear when i set pVertices[0].z = pVertices[1].z = pVertices[2].z = pVertices[3].z =0.0f; if the value is 1.0 it wun show up at all..does anione noes wads causin this ? thanx

Share this post


Link to post
Share on other sites
Advertisement
Since the call to D3DXMatrixOrtho sets the far clipping plane to 1.0, It may just be getting clipped. If that''s the case, then its just a typo in the tutorial. Hope that helps

Share this post


Link to post
Share on other sites
Hmm.. are you following all the steps of the tutorial? There is a typo related to the color of the vertices, but other than that, everything should work as is. What hardware are you using? To test the clipping plane idea, change the ortho matrix to have a farther z value.

Share this post


Link to post
Share on other sites
ok..it works ;> but then...sometimes it shows sometime it dun show..it is bcos of mi hardware ? mi provide a link to the program. if u dun mind could u try it ? thanx alot.

Download here (try clicking refresh if an invalid page shows up)


Edited by - Zer0 on November 12, 2001 4:21:44 AM

Edited by - Zer0 on November 12, 2001 4:22:09 AM

Share this post


Link to post
Share on other sites

  • Advertisement