Jump to content
  • Advertisement
Sign in to follow this  
FGFS

light up scene

This topic is 1312 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi

I can improve my X-Plane FPS by only drawing once instead of twice but at the cost of my texture getting darker. Seems simple but how to

light up the whole scene, can't figure it. I draw alike:

 

                    glBegin(GL_TRIANGLE_STRIP);
                            // draw vertex 0
                            glColor3f(rgb[0], rgb[1], rgb[2]);
                            glVertex3f(terrainMap[x][z][0], terrainMap[x][z][1], terrainMap[x][z][2]);
...

 

I tried glColor3f(rgb[0]+0.1, rgb[1]+0.1, rgb[2]+0.1);

and also added glColor3f(1.0, 1.0, 1.0); before glcolor.

Thanks in advance

Edited by FGFS

Share this post


Link to post
Share on other sites
Advertisement
It sounds like you are accidentally leaving alpha blending enabled. (If alpha s disabled, drawing twice would be visually the same)

Turn it off.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!